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Czy zastanawialiśmy się dlaczego klip filmowy z naszego aparatu cyfrowego posiada monstrualny rozmiar?  
Plik wideo w SP-570UZ, przy czasie jego trwania tylko 39 sekund, z wykorzystaniem kodeka AVI Motion JPEG

®
 i 

dźwięku WAV, ma: 56MB! Nieźle? Jeśli porównamy to do 2-godzinnego filmu HD w rozdzielczości 1280×720 
pikseli z dwiema ścieżkami dźwiękowymi 5.1, który zajmuje 4,5GB – to przyznacie, że wspomniane 56MB dla 39s 
filmu to przesada.  
Pytanie, skąd taka różnica? Przecież jedno i drugie to popularne AVI, ale AVI to tylko kontener, opakowanie.  
O rozmiarze pliku decydują kodeki, które w przypadku naszego aparatu cyfrowego zwią się MJPEG dla wideo, 
natomiast audio kodowane jest do formatu PCM, czyli w kontenerze mamy 2 strumienie danych.  
Ponieważ, JPEG został stworzony do użycia ze statycznymi obrazami, dlatego kompresja filmu polegająca na 
zapisaniu w ciągu jednej sekundy 25 zdjęć nie jest najlepszą metodą, ale na tym właśnie polega zastosowany w 
aparatach MJPEG. 
Wynika z tego, że:  
Kompresowanie jest bardzo ważną częścią obróbki cyfrowego zdjęcia lub filmu. Wymaga zarówno odpowiedniej 
wiedzy jak i praktyki. Trud włożony w opanowanie tego zagadnienia zaowocuje lepszymi zdjęciami i filmami. 
 

Przy zapisie sekwencji (klipów) filmowych w aparatach cyfrowych stosowane są formaty: 

Format zapisu: AVI Motion JPEG
®
  (np. SP-570UZ)  

o VGA: 640 x 480 / 30 kadrów na sekundę Czas nagrywania: 40 sec z dźwiękiem  
o QVGA: 320 x 240 / 15 kadrów na sekundę Czas nagrywania: 29 min z dźwiękiem 

(z kartą pamięci xD typ standard lub M. Dłuższe klipy mogą być kręcone tylko przy zastosowaniu 
xD typ M+) 

o  Nagrywanie dźwięku: format: WAV – ośmiobitowy dźwięk mono (PCM, częstotliwość próbkowania 
8 kHz, rozdzielczość 8 bitów na próbkę, CBR (ang. constant bit rate) - Stała przepływność = 
64kb/s najpopularniejsza metoda reprezentacji sygnału analogowego w systemach cyfrowych, 
jakość słaba. 

Format zapisu: MOV (np. EOS 5D Mark II lub Canon PowerShot SX1 IS) 
o Full HD: 1920 x 1080 (16:9 format)  
o SD/VGA: 640 x 480 (4:3 format)  
o 30 frames per second 
o Video: H.264 [MPEG-4 AVC] 
o Nagrywanie dźwięku: Linear PCM 
o wyjście A/V [NTSC/PAL] - HDMI 

 
Aparaty wyposażone są w wyjście Wideo OUT umożliwiające oglądanie zdjęć bezpośrednio z aparatu na 
telewizorze. Transmisja obrazu w większości w standardzie composite, (umożliwiającego wyświetlanie zdjęć w 
systemie NTSC i PAL). 
 

Spotkane dalej określenia: 
PAL  Phase Alternation Line. Standard telewizji kolorowej w większości krajów Europy. Cechy charakterystyczne to 
m.in. 625 linii obrazu (z przeplotem) i 50 półobrazów (25 ramek) na sekundę. http://pl.wikipedia.org/wiki/PAL   
 
Cinch Popularny standard wtyków stosowanych do łączenia urządzeń audio / wideo (określany również jako RCA). 
Używany głównie do przesyłania analogowego sygnału video composite i dźwięku. 
 
Znakowanie złącz RCA 
Całkowity sygnał wizyjny (CVBS) – żółty 
Fonia analogowa:  

 kanał lewy (L) – biały, 
 kanał prawy (R) – czerwony 

List of video connectors:  http://en.wikipedia.org/wiki/List_of_display_interfaces  
http://www.svideo.com/pctvcables.html 

HDV (High Definition Video) Format zapisu cyfrowego wysokiej rozdzielczości stworzony wspólnie przez firmy 
Sony, Canon, JVC i Sharp. Kamery HDV zapisują na standardowych kasetach MiniDV lub DV. Do kompresji 
wykorzystywany jest algorytm MPEG-2. Format HDV definiuje dwa podstawowe sposoby zapisu: 1080i co oznacza 
1080 linii z przeplotem oraz 720p - 720 linii w trybie progresywnym (proporcje 16:9, rozdzielczość ramki 1280x720 
pikseli) - ten ostatni jest najczęściej wykorzystywany. Kamery zapisujące w formacie HDV to np. Sony HDR-FX1, 
HDR-HC9, JVC JY-HD10U. 
VGA Video Out  http://en.wikipedia.org/wiki/VGA     Vector_Video_Standards2.svg  "Standard VGA" 
W przypadku VGA najczęściej używaną rozdzielczością jest 640x480 przy palecie 16 kolorów. Por. MDA, CGA, 
HGA, EGA, TVGA, SVGA. (ang. Video Graphics Array) 

http://pl.wikipedia.org/wiki/Kiloherc
http://pl.wikipedia.org/wiki/PAL
http://en.wikipedia.org/wiki/List_of_display_interfaces
http://www.svideo.com/pctvcables.html
http://en.wikipedia.org/wiki/VGA
http://upload.wikimedia.org/wikipedia/en/e/e5/Vector_Video_Standards2.svg
http://www.i-slownik.pl/1,1248,rozdzielczosc.html
http://www.i-slownik.pl/1,1334,slot,m.html
http://www.i-slownik.pl/1,248,cga.html
http://www.i-slownik.pl/1,1693,hga.html
http://www.i-slownik.pl/1,470,ega.html
http://www.i-slownik.pl/1,1478,tvga,lub,trident.html
http://www.i-slownik.pl/1,1398,svga.html


 
Composite Video znane również jako acronim CVBS ("Color, Video, Blank i Sync".) - jest wyjściem sygnału wideo 
telewizji analogowej!. sygnał Composite Video czyli Całkowity Zespolony Sygnał Wizji 
 
Overscan.  
W telewizorach z kineskopem lampowym nieuniknione. Overscan jest odgórnie ustalony i wynosi około 5-10%. 
Pierwsze kineskopy nie były idealne i wraz ze zmianą luminancji zmieniały się proporcje obrazu, a dokładnie wraz 
ze zwiększaniem jasności zwiększał się rozmiar kadru. Takie zjawisko występuje i w obecnych kineskopach, ale 
już nie na tak wielką skalę. W komputerowych monitorach CRT również występuje overscan, ale do obrazu dodaje 
się dookoła czarną ramkę, dlatego wydaje się, że obraz na monitorze CRT mieści się dokładnie w granicach.  
Wg: http://en.wikipedia.org/wiki/Overscan 
opcja obcinająca krawędzie obrazu w celu usunięcia ewentualnych zakłóceń powodowanych przez źródło sygnału. 
Overscan nie dotyczy monitorów i telewizorów LCD.  
AVI (Audio Video Interleave) to tylko kontener danych audiowizualnych, opakowanie.  
Format AVI (http://pvdtools.sourceforge.net/aviformat.txt ) rozszerza technologię formatu RIFF (Resource 
Interchange File Format - sposób zapisywania danych poprzez ich podział na części) dodając dwie lub opcjonalnie 
trzy „części”. Pierwsza z nich (hdrl) stanowi nagłówek pliku i zawiera metadane określające plik video, takie jak 
rozmiar obrazu i liczbę klatek. Druga „część” (movi) zawiera właściwe dane audiowizualne. Trzecia opcjonalna 
(idxl) gromadzi informacje o położeniu „części” wewnątrz pliku AVI. O rozmiarze pliku decyduje kodek, który w 
przypadku aparatu cyfrowego SP-570UZ zwie się MJPEG, natomiast audio kodowane jest formatem WAV.  
WAVE też bazuje na formacie RIFF, poszerzając go o informacje o strumieniu audio, takie jak użyty kodek, 
częstotliwość próbkowania czy ilość kanałów. 
JPEG został stworzony do użycia ze statycznymi obrazami, dlatego zastosowana w aparatach kompresja filmu 
MJPEG polegająca na zapisaniu w ciągu jednej sekundy 30 zdjęć nie jest wyszukaną metodą.  
Pliki w formacie WAVE mogą być zapisane przy użyciu dowolnych kodeków audio, zazwyczaj stosuje się 
nieskompresowany format PCM, który powoduje, że pliki zajmują dużo miejsca. Format WAV został częściowo 
wyparty przez formaty kompresji stratnej. Plik w tym formacie jest około 12 razy większy od takiego samego utworu 
zapisanego jako MP3. Ale dzięki swojej prostocie, nadal znajduje szerokie zastosowania.  
Szczegółowy opis budowy pliku WAV.  
Kodek jest skrótem od "koder/dekoder", co oznacza urządzenie lub program zdolny do przekształcania strumienia 
danych lub sygnału (Lista kodeków  http://www.fourcc.org/ ).  
PCM (ang. Pulse Code Modulation) – to najpopularniejsza metoda reprezentacji sygnału analogowego w 
systemach cyfrowych.  
Kompresja stratna — metody zmniejszania liczby bitów potrzebnych do wyrażenia danej informacji. 
 

Poniżej omówiono standard AVI Motion JPEG
®
  oraz Composite Video. 

 
Schemat blokowy cyfrowego aparatu fotograficznego 

http://en.wikipedia.org/wiki/Color
http://en.wikipedia.org/wiki/Video
http://en.wikipedia.org/wiki/Blanking_%28video%29
http://en.wikipedia.org/wiki/Sync
http://en.wikipedia.org/wiki/Overscan
http://pvdtools.sourceforge.net/aviformat.txt
http://www.sonicspot.com/guide/wavefiles.html
http://www.fourcc.org/


Wideo jako sekwencja obrazów JPEG – czyli: 
 
Co to jest MJPEG (kompresja MJPEG) lub kompresja JPEG? 
http://en.wikipedia.org/wiki/Motion_JPEG  
Algorytm kompresji MJPEG jest jednym z częściej stosowanych standardów podczas przechwytywania sygnału 
wideo i kompresji obrazu. Format stosowany zarówno w kompresji sprzętowej jak i programowej. Zasada polega 
na traktowaniu każdej klatki filmu jako oddzielnego obrazu, mamy tutaj do czynienia z kompresją wewnątrz 
klatkową, informacja w niej zapisana jest niezależna od informacji w innych sąsiadujących, tj. poprzedzających i 
następujących klatkach. Każda klatka jest kompresowana przy zastosowaniu algorytmu jaki jest używany w 
standardzie JPEG, pozwala to na kompresję poszczególnych ramek w zakresie - średnio 10:1 do 20:1, redukcję 
ich rozmiarów i szybkości przesyłania. Rejestruje ona w całości wszystkie obrazy pośrednie, umożliwia to później 
swobodne redagowanie ramek. 

 
Schemat kompresji przebiega w/g następujących kroków: 

- Dane wejściowe są w postaci RGB24, 
- Transformacja przestrzeni barw na komponenty YCbCr (YUV),  
- Proces dyskretnej transformacji kosinusowej, 
- Kwantyzacja współczynników transformaty 
- Kodowanie długości ciągów (run-length encoding - RLE) 
- Kodowanie algorytmem Huffmana, 
- FILM (plik wynikowy - strumień wideo składa się ze strumienia klatek wideo) 

Jak wykazały badania, oko ludzkie jest znacznie bardziej wyczulone na zmianę jasności niż barwy. Komórki 
widzenia czarno-białego wywierają większy wpływ na wzrok niż komórki widzenia dziennego (kolorowego). Dlatego 
standard JPEG bierze pod uwagę ten fakt, że ludzkie oko jest bardziej wrażliwe na jaskrawość koloru niż na jego 
odcień. Jeśli będziemy przekształcić dane z 3 kanałów RBG tak, aby jasność była przechowywana w jednej 
składowej, a kolory w pozostałych dwóch, to okaże się, że możemy usunąć większość informacji o kolorze, bez 
zauważalnego pogorszenia wyglądu obrazu. Tutaj odbywa się transformacja koloru RGB do YCbCr (lub inaczej 
YUV dla analogowego systemu kodowania ) i obniżenie rozdzielczości. W transformacji przestrzeni barw następuje 
dekorelacja składowych, które są kodowane niezależnie od siebie, umożliwia to kodowania różnych składowych z 
różną jakością (kompresją). 
Transformacja ta rozkłada obraz w kolorach RGB na składową luminancyjną (popr. Luma) - jasność (Y) i dwie 
składowe różnicowe chrominancyjne [zabarwienia - antyniebieska niebieski / żółty Cb (Chromablue)– i składowa 
antyczerwona czerwony / zielony Cr (Chromared) - wartości odpowiadające za nasycenie barwy, oznaczają 
odpowiednio jak bardzo niebieski i czerwony jest dany kolor - wartości te wskazują, jak wiele jest w tym kolorze, 
odpowiednio  niebieskich i czerwonych]. Komponenty obrazu możemy uważać za warstwy, na które dzielimy obraz, 
by uprościć późniejszy proces kodowania, a które po zdekodowaniu i złożeniu dadzą pierwotny obraz. 
Założeniem dla poprawnej transformacji jest, aby wszystkie składowe barw były liczbami nieoznaczonymi 
całkowitymi o długości minimum ośmiu bitów (typ byte lub unsigned char Typ znakowy w praktyce powinno być 
używane tam, gdzie operujemy na bajtach i oczekujemy wartości {0, 1, 2, ..., 255} ). 

http://en.wikipedia.org/wiki/Motion_JPEG


Najpierw określana jest wartość luminacji na podstawie wszystkich trzech składowych RGB i zapisywana jest dla 
każdego piksela osobno (nie zawiera ona informacji o kolorze).  

Y = 0,299 R + 0,587 G + 0,114 B 
Następnie na podstawie właśnie wcześniej obliczonej składowej luminacji określane są różnicowe składowe 
chrominacji.  

Cb = -0,1687 R – 0,3313 G + 0,5 B +128 
Cr = 0,5 R – 0,4187 G – 0,0813 B +128 

W rezultacie otrzymujemy 3 obrazy (warstwy) niosące różną informację o obrazie.  
W modelu YCbCr dominującym czynnikiem jest Y; Cb i Cr mają mniejszy wpływ na wygląd obrazu. 
Ta transformacja pomiędzy dwójką przestrzeni barwnych, jest bezstratna, tj. nie może przy niej dojść do żadnej 
straty informacji o obrazie.  
Przykłady podane poniżej pokazują w jaki sposób przebiega transformacja obrazu z przestrzeni typu TrueColor 
RGB do przestrzeni barwnej YCbCr. 
Posłużyłem się istniejącym w sieci http://en.wikipedia.org/wiki/Standard_test_image popularnym obrazkiem Lena 
(Lenna). 

 
Po transformacji do przestrzeni barw  YCbCr możemy zauważyć, że najwięcej informacji zawartych jest w obrazku 
z wartościami Y, podczas gdy dalsze dwa obrazki zawierają barwy bardziej szare.  

 
Jeszcze większe różnice między poszczególnymi częściami składowymi zobaczymy na histogramach (GIMP). 
Wyjaśnienie tej dysproporcji jest logiczne – pierwotny obraz zawierał małą ilość barw, wzgl. barwy nie były  
rozmieszczone równomiernie. 
  
Dalej następuje podpróbkowanie (subsampling) składowych chrominancji CbCr- czyli redukcja 
rozdzielczości. 
Składowe chrominancyjne mogą zostać poddane próbkowaniu ze zmniejszoną rozdzielczością. Polega to na 
uśrednieniu wartości składowych chrominancji dla bloku 2 x 2 piksele. Na każde 2 x 2 punkty luminancji (Lumy) Y 
przypada zaledwie jeden punkt różnicowy chrominancji Cb i jeden punkt różnicowy chromacji Cr. 
Uwaga: Przy obrazach w gradacji szarości wykorzystuje się tylko składową Y (brak podpróbkowania)!. 
 

 

http://en.wikipedia.org/wiki/Lenna


  
 
lub inaczej:  
 

 
 

Dla reprezentacji 2 x 2 czyli 4 pikseli i formatu podpróbkowania  4:4:4 potrzebujemy sumarycznie: 
 (4 piksele) * (8-bit/piksel Y + 8-bit/piksel Cr + 8-bit/piksel Cb) = 96 bit. 
Dla reprezentacji 2 x 2 czyli 4 pikseli i formatu podpróbkowania  4:2:0 potrzebujemy sumarycznie: 
 (4 piksele) * (8 -bit/piksel Y + 8-bit Cr + 8-bit Cb) = 48 bit nastąpiło zmniejszenie danych rastrowych o 50%. 
Rozdzielczość pozioma i pionowa jest zmniejszana o połowę (format 4:2:0) "High chroma subsampling". 
(4:2:2) "Medium chroma subsampling" - połowa z rozdzielczości poziomej barw jest usuwana (Cb i Cr), podczas 
gdy w pełnej rozdzielczości jest zatrzymywane w kierunku pionowym, w stosunku do luminancji. Jest to znane 
także jako podpróbkowanie barwy 2x1, i jest typowe dla aparatów cyfrowych.  
Czyli "podpróbkowanie", określa ile bitów ma być przeznaczonych na sygnał jasności a ile dla koloru. 
Powyższe dotyczy zamiany z RGB na YUV12, do zapisu informacji o obrazie jest w nim wykorzystywane 12 bitów. 
Innym formatem YUV jest YUV9. W jego przypadku składowa chrominancji opisuje grupę nie 2x2 piksele, lecz 4x4 
piksele. Czyli dla 16 sąsiednich pikseli zapisywana jest taka sama informacja o kolorze. W sumie daje to średnio 9 
bitów na piksel. Kodowanie koloru – daje oszczędność miejsca, zmiana bezstratna. 
Podział obrazu na bloki. (Dekompozycja obrazu na bloki) 
Kiedy już mamy "podpróbkowane” składowe YCbCr (lub inaczej YUV dla analogowego systemu kodowania), w 
kolejnym kroku stosuje się podział każdej składowej (warstwy) obrazu na nie zachodzącego na siebie bloki 8x8 
pikseli (w przypadku MPEG2 o wymiarach 16x16 pikseli). 



 
 
Z powodu podziału obrazu na bloki 8x8, pojawia się problem, gdy wymiary obrazu nie są całkowita wielokrotnością 
liczby 8. Wtedy obraz rozszerzamy do rozmiarów będących wielokrotnością 8 poprzez uzupełnienie bloków 
leżących na prawej i dolnej krawędzi obrazu (powtórzenie ostatniej kolumny/wiersza odpowiednią liczbę razy) do 
całkowitej wielokrotności 8. Można to wykonać poprzez: 

 uzupełnienie zerami – sposób najprostszy ale jednocześnie najgorszy, 
 uzupełniamy kolorem ostatniego piksela, 
 uzupełniamy takimi pikselami, aby odwrotna transformacja kosinusowa (IDCT) zwróciła wartości pikseli z 

obrazu jak najbliższe wartości oryginalnych. 
 
Ponieważ przetwarzanie każdego bloku 8x8 odbywa się bez odniesienia do innych, dalej będę koncentrować się 
tylko na pojedynczym bloku. W szczególności skupię się tylko na bloku składowej Lumy Y. Przy okazji można 
zauważyć że jaśniejszym pikselom składowych Y Cr Cb odpowiadają większe wartości, oraz że Luma Y wykazuje 
większe zmiany niż chrominancje (co pokazano powyżej). 
Następny krok - Transformacja przy użyciu DCT – dyskretnej transformaty kosinusowej  
(w opisie będę stosował pewne skróty myślowe, ponieważ materiał szczegółowy, matematyka, może być dla 
niektórych osób nużąca)  
Na każdym z tych bloków dokonywana jest seria obliczeń, nazywana dyskretną transformacją kosinusową (DCT 
– Discrete Cosine Transform).  
Tutaj właśnie rozpoczyna się ważny etap kompresji JPEG, dzięki któremu otrzymywane są dobre efekty kompresji 
JPEG.  
W większości przy transformacjach prowadzi się transfer (czy mapowanie) przetwarzanego sygnału z domeny 
czasu (przestrzennej) do domeny częstotliwości, ponieważ istnieje domniemanie, że przykładowo obrazy 
rzeczywistych przedmiotów nie zawierają dużo energii w wyższych częstotliwościach i jest wtedy dobrze 
zgromadzić jak największa ilość odpowiednich danych do małej ilości współczynników. Kodowanie jako wynik miało 
by prowadzić do całkowitego obniżenia ilości bitów niosących informację wizualną (psychowizualna redundancja).  



Celem transformacji DCT jest to, by zamiast przetwarzania oryginalnych składników obrazu, można było stwierdzić 
które jego elementy to istotne fragmenty obrazu niosące istotną informację i wpływające na jego jakość, a które to 
„szum”, jakiego nie zauważa ludzkie oko, i który nie jest bardzo istotny. 
DCT pozwala na dyskretne przejścia pomiędzy barwami. Po przekształceniu obrazu za pomocą DCT możemy 
pracować z pewnymi „częstotliwościami” obecnymi w oryginalnym obrazie. Te przestrzenne częstotliwości są ściśle 
związane z ilością detali obecnych w obrazie. Wysokie częstotliwości przestrzenne związane są z dużą ilością 
detali, natomiast niskie z małą ilością.  
Transformacja z uwagi na swoją złożoność, jest operacją czasochłonną i wykonywanie jej w czasie rzeczywistym 
dla złożonych sygnałów (obraz) wymaga dużej mocy obliczeniowej. Jest to związane z funkcją, która wymaga 
wykonania dużej ilości mnożeń i dodawań. Pojedyncza dwuwymiarowa operacja obliczenia DCT lub IDCT na bloku 
o rozmiarze 8x8 pikseli wymaga kilkuset cykli instrukcji w typowym procesorze DSP. 
Transformata DCT jest transformatą bezstratną, która przekształca zbiór danych, który został spróbkowany z 
ustaloną częstotliwością próbkowania w jego komponenty częstotliwościowe. Liczba próbek musi być skończona i 
być wielokrotnością 2 w celu skrócenia czasu obliczeń.  
Dyskretna transformata kosinusowa służy do przetwarzania dyskretnego (fj. próbkowanego) sygnału otrzymanego 
np. z  matrycy CCD. 
DCT konwertuje tablicę liczb, które przedstawiają amplitudy sygnału w różnych punktach w czasie, w inną tablicę 
liczb, z których każda reprezentuje amplitudę pewnych częstotliwości komponentów z oryginalnej tablicy. 
Transformata DCT, może być przeprowadzona kolejno jako, transformata jednowymiarowa najpierw wierszami, 
następnie kolumnami lub najpierw kolumnami, następnie wierszami. W obu przypadkach wynik będzie identyczny.  
Dla kompresji JPEG z dwuwymiarową DCT (2D-DCT) jest stosowany M = N = 8. 
Dla sygnałów rzeczywistych transformata DCT ma również wartości rzeczywiste. 
Znalezienie dyskretnej dwuwymiarowej transformacie kosinusowej (2D DCT) sprowadza się do złożenia 
dwóch transformat jednowymiarowych: 

 najpierw stosujemy 1DCT wierszami m a potem, kolumnami n macierzy otrzymanej w wyniku pierwszej 
transformacji     lub  

 stosujemy 1DCT (pionowo) wzdłuż każdej kolumny n a potem, (poziomo) wzdłuż każdego wiersza m 
macierzy otrzymanej w wyniku pierwszej transformacji. 

Wyznaczenie transformaty dwuwymiarowej za pomocą jednowymiarowych transformacji, pokazano na poniższym 
rysunku: 

 
Jest to bardzo ważna własność, przedstawia, że funkcje bazowe mogą być - obliczane rozłącznie i następnie 
wyniki mnożone. To zmniejsza ilość operacji matematycznych (mnożeń i dodawań) tym samym zwiększając 
współczynnik sprawności obliczeń. 
W ramach procesu dyskretnej transformaty kosinusowej uzyskamy zbiór - tablicę wyników –> macierz 
współczynników transformacji DCT. DCT nie jest definiowana dla M < 2. 

Np.: wynik obliczenia współczynników DCT dla jednego z bloków („kafelków”) 8x8 wzorcowego obrazu lena Y: 
F(u,v) = T*X*T’  

Gdzie:  
T – macierz obliczonych wartości wag transformaty bazowej jednowymiarowej transformaty dla wierszy; 
X – macierz danych;  
T ’ – macierz transportowana obliczonych wartości wag transformaty bazowej jednowymiarowej dla kolumn; 

 
 



 
Pierwszy element w tablicy wyników jest zwykłą średnią wartością wszystkich próbek wejściowych w tablicy i jest  
w literaturze określany jako współczynnik DC -Direct current.  
Wszystkie pozostałe elementy przekształcenia w każdej tablicy wyników wskazują amplitudy częstotliwości 
konkretnych komponentów tablicy wejściowej, i są nazywane współczynnikami AC - Alternating current. 
Częstotliwościowa wartość próbki określana dla każdej częstotliwości jest obliczana w drodze średniej ważonej dla 
całego zestawu. Te współczynniki wagowe są jak cosinusy fali, których częstotliwości są proporcjonalne do 
wyników tablicy indeksów.  
 
Przejdziemy do naszego przykładu zastosowania w bloku Y wzorcowego obrazu j/w Lena: 

 
 

 
To przesunięcie - offset jest konieczne, ponieważ kolejno w DCT i w kwantyzacji otrzymamy mniejsze wartości 
współczynników (redukuje wymagania dotyczące precyzji przy obliczaniu DCT), a tym samym ma miejsce lepsza 



kompresja. To ograniczenie zakresu wokół 0 ułatwia realizację funkcji cosinus DCT, dla mniejszych wartości jest 
symetryczna. 

 
Po normalizacji: 

 
 

 



 
Przykład: obliczenia współczynników DCT dla jednego z bloków („kafelków”) 8x8 wzorcowego obrazu lena Y. 

 
Jak już wspomniano, współczynnik F0,0 zwany jest współczynnikiem DC -Direct current, natomiast pozostałe 63 
współczynniki nazywane są współczynnikami AC - Alternating current. 
Uwzględniając znak, są potrzebne P + 3 bity, by reprezentować dowolną wartość współczynnika DCT. Dlatego po 
zakończeniu transformacji kosinusowej otrzymujemy macierz DCT (8x8), która wymaga większej pamięci niż 
pierwotna macierz próbek; w macierzy 2D-DCT każdy element wymaga użycia 11 bitów, podczas gdy każda 
próbka wymagała użycia tylko 8 bitów. więc nie wystąpiła na razie żadna kompresja danych. 
Dlatego trzeba zastosować jakieś działanie w celu obniżenia wymagań dotyczących pamięci. Tym działaniem jest 
kwantyzacja elementów transformaty.  Kwantyzacja polega na dzieleniu każdego ze współczynników transformaty 
DCT przez odpowiadający mu element tablicy kwantyzacji. 
Kwantyzacja. 
Po transformacji otrzymaliśmy macierz wartości rzeczywistych, którą poddamy kwantyzacji. Kwantyzacja, czyli 
zastąpienie danych zmiennoprzecinkowych przez liczby całkowite. Część danych w ten sposób tracimy – dlatego 
kompresja JPEG jest kompresją stratną. 
Otrzymana w wcześniejszym kroku macierz 64 współczynników transformaty F(u,v) w bloku Lena:  

 
poddane zostaną teraz kwantyzacji liniowej przy użyciu macierzy używanej do kwantyzacji współczynników Lumy 
(luminancji) Q(u,v) o postaci: 

 
Tabela kwantyzacji dla współczynników luminancji - Q50 

Tabela kwantyzacji jest parametrem algorytmu. Komitet JPEG przygotował tabele standardowe dobrane na 
podstawie eksperymentów z rzeczywistymi obrazami oraz rzeczywistymi urządzeniami, inne dla luminancji inne dla 
chrominancji. W standardzie JPEG zamieszczone są 4 tablice współczynników kwantyzacji, jednakże żadna z nich 
nie jest obowiązkowa. 
Jak widać największe wartości w macierzy kwantyzacji mają współczynniki poniżej przekątnej (prawy dolny róg) i 
odpowiadają one współczynnikom macierzy F(u,v) o wyższych częstotliwościach.   
Kwantyzacja wykorzystuje fakt, że ludzkie oko jest bardziej wrażliwe na niskie niż wysokie częstotliwości (mała 
wrażliwość na amplitudę szybkich zmian jasności) i poprzez kwantyzację, która polega na dzieleniu każdego ze 



współczynników transformaty F(u,v) przez odpowiadający mu element tabeli kwantyzacji Q(u,v) i zaokrągleniu 
wyniku do najbliższej liczby całkowitej. 
Typowo większość współczynników AC transformaty Fu,v ma małe wartości, tym mniejsze im wyższej 
częstotliwości odpowiadają (małe znaczenie dla percepcji obrazu), po kwantyzacji ulegają zaokrągleniu do zera, co 
jest równoznaczne z wymazaniem wyższych częstotliwości. 
Tablica kwantyzacji liniowej ma wymiar równy wymiarowi bloku 8x8 i zawiera dla każdego współczynnika 
transformacji wartość progu i przedział kwantyzacji. Tę samą tablicę stosujemy do wszystkich bloków.  
Kwantyzacja wyraża się wzorem: 

 
Gdzie:  F(u,v) - współczynniki transformacji,  
  Q(u,v) — tablica kwantyzacji,  
  round [x] - funkcja zaokrąglająca [x] do najbliższej liczby całkowitej większej bądź równej  
  liczbie rzeczywistej [x]. 
Dzieląc wszystkie współczynniki Fu,v przez stałą wartość Q(u,v) kontrolujemy współczynnik kompresji, po 
zaokrągleniu wyniku do najbliższej liczby całkowitej. 

 
 



Tak więc nasza macierz transformaty F(u,v) bloku Lena będzie po  kwantyzacji dla  luminancji - Q50  

 
Poniżej zamieszczam tablicę używaną do kwantyzacji współczynników chrominancji. Współczynniki w 
podanych tablicach zostały wyznaczone na podstawie psychowizualnej oceny testowych obrazów. 

 
Tabela kwantyzacji dla współczynników chrominancji. 

Jak widać współczynniki w tabeli dla kwantyzacji chrominancji są większe i co za tym idzie zdecydowana 
większość składowych Cr Cb po kwantyzacji będzie równa zero i zostanie usunięta. Natomiast po kwantyzacji 
luminancji składowych Y zostanie więcej. Jak już wspomniano, oko ludzkie jest bardziej wyczulone na zmianę 
jasności (luminancji) niż na zmianę barwy (chrominancji). Dzięki temu taka kwantyzacja będzie bardziej skuteczna. 
Gdy kodujemy obrazy czarno-białe, używamy jedynie składowej luminancji. 
Główną zaletą takiej metody kwantyzacji jest szybkość działania - wykonywane jest tylko dzielenie. Ponadto jest 
ona obarczona niewielkim błędem oraz pozwala ograniczyć występowanie efektu blokowego (ta sama tablica 
kwantyzacji do wszystkich bloków). 
 
W przypadku kompresji JPEG obrazów, kiedy tworzymy plik, algorytm prosi o parametr kontroli jakości obrazu czyli 
w jakim stopniu obraz ma być skompresowany (przykładowo w GIMP-ie):  

 
Możemy ustalić tak zwany poziom jakości (guality lewel), oznacza się go jako QL. Jest to współczynnik o 
wartościach całkowitych od 1 do 100, określający jakość zdekompresowanego obrazu oraz o stopniu kompresji 
wyjściowego obrazu. Wyższa wartość QL odpowiada wyższej jakości obrazu i większym rozmiarem pliku. QL 
równy 1 oznacza najwyższy współczynnik kompresji obrazu ale najniższą jakość zdekompresowanego obrazu. 
Podana powyżej „standardowa” macierz kwantyzacji oznaczana Q50 odpowiada współczynnikowi QL = 50, stanowi 
pewne wyważenie pomiędzy jakością a współczynnikiem kompresji. 

Współczynnik skalowania tablicy kwantyzacji - α zależy od QL w następujący sposób: 

 



Z wykresu wynika, że gdy chcemy skompresować obraz przy użyciu innej wartości współczynnika QL, to: 
 dla QL ≥ 50 mnożymy współczynniki macierzy Q50 przez współczynnik skalowania 2 -  QL/Q50 (wartość od 

1 do 0,02 – QL=99) 
 dla QL < 50 mnożymy współczynniki macierzy Q50 przez współczynnik Q50/QL (wartość od 1 do 10) 

 (wykres zakończono dla wartości współczynnika skalowania α równego 10, gdy QL = 5 !) 
Po wymnożeniu, współczynniki nowej macierzy kwantyzacji są zaokrąglane i obcinane, aby ich wartości były 
liczbami całkowitymi z przedziału od 1 do 255. 
Przykładowo współczynnikowi QL = 90 odpowiada macierz: 

 
Gdzie: Q90 = 0,2*Q50 dla pierwszego współczynnika mamy: 0,2*16 = 3,2 ~ 3 itd., gwarantuje nam ona lepszą jakość 
obrazu zdekompresowanego, ale gorszy współczynnik kompresji. 
Współczynnikowi QL = 10 odpowiada macierz: 

 
Kwantyzacja dla różnych wartości QL wyraża się teraz wzorem: 

 
 
Uwaga: 
parametr kontroli jakości obrazu, czyli w jakim stopniu obraz ma być skompresowany ustala producent aparatu 
wprowadzając możliwość ustawienia przez nas IMAGE QUALITY -> Compression np.: FINE lub NORMAL. 
Tabela kwantyzacji jest zawsze zapisywana w danych EXIF.  
Dla zainteresowanych:  
JPEGsnoop – dekodowania plików JPEG  
http://www.impulseadventure.com/photo/jpeg-snoop.html?ver=1.2.0  
Obsługiwane typy plików: 

 . JPG - zdjęcia JPEG  

 . THM - miniatury dla RAW Photo / Film Pliki  

 .AVI * - AVI Movies 

 .DNG - Digital Negative RAW Photo  

 . CRW. CR2. NEF. ORF. PEF - RAW Photo  

http://www.impulseadventure.com/photo/jpeg-snoop.html?ver=1.2.0


 .MOV * - QuickTime Movies, QTVR (Virtual Reality / 360 Panoramic) 

 .PDF - Adobe PDF Documents   
Każda fotografia cyfrowa zawiera mnóstwo ukrytych informacji - JPEGsnoop został napisany, aby odsłonić te 
szczegóły dla tych, którzy są ich ciekawi. 
Nie tylko można określić różne ustawienia, które były wykorzystywane w cyfrowym aparacie fotograficznym - 
metadane zdjęcia (EXIF, IPTC), ale można także wyodrębnić informacje, które wskazują na jakość i charakter 
kompresji obrazu JPEG wykorzystany przez aparat co zapisano w pliku. 
Np. dla pliku AVI Motion JPEG

®
  VGA 640x480 30fps (ramek/s) MAGE QUALITY -> Compression:?  

AVI is MotionJPEG 
Najpierw pokazuje dane miniaturki (JPEG Thumbnail), potem poprzez: 
  Use [Tools->Img Search Fwd] to locate next frame – przeglądamy klatka po klatce 

 
Przykładowe odczytane dane SP-570UZ 

Film dla pliku AVI Motion JPEG
®
  VGA 640x480 30fps (ramek/s) MAGE QUALITY -> Compression:?  

AVI is MotionJPEG 
Najpierw pokazuje dane miniaturki (JPEG Thumbnail), potem poprzez: 
  Use [Tools->Img Search Fwd] to locate next frame – przeglądamy klatka po klatce 
*** AVI File Decoding ***  
Image Size = 640 x 480 
Precision=8 bits 
Destination ID=0 (Luminance) 
    DQT, Row #0:  16  11  10  16  24  40  51  61  
    DQT, Row #1:  12  12  14  19  26  58  60  55  
    DQT, Row #2:  14  13  16  24  40  57  69  56  
    DQT, Row #3:  14  17  22  29  51  87  80  62  
    DQT, Row #4:  18  22  37  56  68 109 103  77  
    DQT, Row #5:  24  35  55  64  81 104 113  92  
    DQT, Row #6:  49  64  78  87 103 121 120 101  
    DQT, Row #7:  72  92  95  98 112 100 103  99  
    Approx quality factor = 50.00 (scaling=100.00 variance=0.00) dla pierwszej klatki potem QL rośnie 
  ---- 
  Precision=8 bits 
  Destination ID=1 (Chrominance) 
    DQT, Row #0:  17  18  24  47  99  99  99  99  
    DQT, Row #1:  18  21  26  66  99  99  99  99  
    DQT, Row #2:  24  26  56  99  99  99  99  99  
    DQT, Row #3:  47  66  99  99  99  99  99  99  
    DQT, Row #4:  99  99  99  99  99  99  99  99  
    DQT, Row #5:  99  99  99  99  99  99  99  99  
    DQT, Row #6:  99  99  99  99  99  99  99  99  
    DQT, Row #7:  99  99  99  99  99  99  99  99  
    Approx quality factor = 50.00 (scaling=100.00 variance=0.00) 
Number of Img components = 3 
    Component[1]: ID=0x01, Samp Fac=0x21 (Subsamp 1 x 1), Quant Tbl Sel=0x00 (Lum: Y) 
    Component[2]: ID=0x02, Samp Fac=0x11 (Subsamp 2 x 1), Quant Tbl Sel=0x01 (Chrom: Cb) 
    Component[3]: ID=0x03, Samp Fac=0x11 (Subsamp 2 x 1), Quant Tbl Sel=0x01 (Chrom: Cr) 
 
 
Po zakończeniu transformacji kosinusowej otrzymamy macierz DCT, która wymaga większej pamięci niż pierwotna 
macierz próbek; a mianowicie każdy element wymagał użycia P + 3 = 11 bitów, podczas gdy każda próbka 
wymagała użycia tylko 8 bitów. Pojawia się więc pytanie, co zyskaliśmy po zastosowaniu kwantyzacji?. Po 
kwantyzacji liczba bitów zmniejsza się do P + 3 – log2 (Q(u,v), czyli w przypadku tablicy kwantyzacji dla 
współczynników luminancji - Q50 , gdzie najmniejszy współczynnik kwantyzacji = 10, wystarczy liczba 

P + 3 – [log2 10] = P bitów  
do zakodowania jednej danej wynikowej kwantyzatora. 
 
Właściwe w tym miejscu można by zakończyć szczegóły opisu algorytmu systemu bazowego (Baseline) 
JPEG, biorąc pod uwagę, że użytkownik nie ma żadnego wpływu w zakresie dalszego przebiegu algorytmu.  
 
Ale dla zamknięcia tematu trzeba jeszcze omówić końcowe etapy Kodowanie długości ciagów (run-length 
encoding - RLE) oraz Kodowanie algorytmem Huffmana. Które mają na celu zmniejszenie objętości macierzy. 
Pozwalają na bezstratne zmniejszenie ilości informacji przy akceptowalnym poziomie strat, a polega to na 
przypisaniu poszczególnym powtarzającym się ciągom pewnych kodów. Wartościom występującym często, a wiec 
zajmującym najwięcej miejsca przypisywane są krótkie kody, a występującym rzadko - długie. Kody określone są w 
specjalnej tabeli służącej później do dekodowania.   



 

Przestawienie zygzakowate macierzy DCT i kodowanie Huffmana. 
 

 
 

W tym kroku skwantowane współczynniki transformaty są układane za pomocą tak zwanego uporządkowania zyg-
zak. Następuje konwersja macierzy (tablicy) współczynników do postaci wektora. Czyli zmiana kolejności 64 
składników DCT, algorytmem zig-zag (opisany przez A.G. Teschera w 1978). Współczynniki transformaty są 
grupowane jak na rysunku: 

 
 



 
Link do animacji: http://nptel.iitm.ac.in/courses/Webcourse-

contents/IIT%20Kharagpur/Multimedia%20Processing/animations/fig%209.8.swf 
Dzięki zastosowaniu ZigZak, skwantowana tablica dwuwymiarowa F(u, v) przekształcana jest w tablicę 
jednowymiarową (wektor). 
Jak widać na rysunkach, dane zostają kolejno, zygzakiem od lewego-górnego rogu macierzy do dolnego-prawego, 
przepisywane do 64-elementowego wektora.  
Dzięki zastosowaniu takiej reorganizacji tablicy, wartości niezerowe w wektorze występują koło siebie. Tym samym 
zera tworzą dłuższy ciąg niż przy normalnym obejściu tablicy. Uzyskuje się ciąg (wektor) rozpoczynający się 
współczynnikiem DC, po którym następują 63 współczynniki AC.  
W takim ciągu często po kilka sąsiednich współczynników AC (podciągów) ma te same wartości np. zero.  
Możemy wtedy zastosować kodowanie długości serii, polegające na generowaniu słów kodowych dla serii takich 
samych symboli, za pomocą kodowania RLE - (run length encoding – kodowanie długości serii). Uzyskana 
reprezentacja składa się z par typu (RRRR – liczba powtórzeń, Wartość) wyznaczonych dla kolejnych 
fragmentów ciągu utworzonych przez współczynniki o takich samych wartościach. 
Kodowanie RLE, ma jednak sporą nadmiarowość – wszystkie wartości pikseli są traktowane w ten sam sposób, 
mimo iż niektóre z nich występują częściej niż inne i w związku z tym zasługują na większą uwagę. Legło to u 
podstaw sposobu kodowania znanego jako kompresja Huffmana (Huffman encoding). 
Liczby określające kod RLE są kodowane ze zmienną długością słowa (VLC ang. variable length coding), za 
pomocą kodów Huffmana. 
W systemie bazowym JPEG metodę Huffmana stosujemy do kodowania wszystkich współczynników, dwa zestawy 
tabel, jeden do współczynników DC, a drugi do kodowania współczynników AC.  
 

Bezstratna (entropowa) kompresja współczynników transformaty 
Kompresja składowych stałych transformat - DC = FQ(0, 0) 

 
DPCM (ang. Differential Pulse Code Modulation) współczynników DC, to = różnica dwóch współczynników DC, 
dwóch kolejnych bloków, kodowanie binarne sekwencji elementów DC wykonuje się techniką predykcji liniowej 
rzędu jeden. Dla pierwszego bloku jako predykcję wartości DC przyjmujemy 0. 

http://nptel.iitm.ac.in/courses/Webcourse-contents/IIT%20Kharagpur/Multimedia%20Processing/animations/fig%209.8.swf
http://nptel.iitm.ac.in/courses/Webcourse-contents/IIT%20Kharagpur/Multimedia%20Processing/animations/fig%209.8.swf


Przykład: Jeśli współczynniki DC kolejnych bloków wynoszą np.: 
DC = [DC0, DC1, . . . , DCm−1] 
DC = [13,13,10,11,11,10….] 

Wartości wektora przyrostów DPCM wyniosą: 
diff = Δ = [Δ 0, . . . , Δ m−1]: 

Gdzie: Δ 0 = DC0, Δ n = DCn − DCn-1, n = 1, 2, . . . ,m – 1, m – liczba bloków obrazu 
DCn-1 - predyktor 

Różnica diff jest zazwyczaj mała, co umożliwia efektywne stosowanie do kodowania metody DPCM. 
Różnica diff zostaje zakodowana za pomocą tabeli kodów Huffmana (dla bazowego JPEG tabela ma 12 wierszy).   
Dla powyższego ciągu współczynników, otrzymamy następujące diff: 13, 0, -3, + 1, 0, -1, … 
 
Kod DPCM wyrażany jest przez reprezentację składającą się z par typu: (SSSS, wartość): 
 
SSSS [Category, Length] – wskazuje kategorię diff (odpowiada jednej z 12 kategorii, w tabeli wartości różnic 
diff.) 
SSSS jest używany jako indeks do odszukania w tablicy Huffmana słowa kodu,  odpowiadającego różnicy diff, przy 
czym słowo kodu zależy od bieżąco używanej tabeli Huffmana.  
JPEG podał przykłady tego typu tabel jednej dla luminancji i jednej dla chrominancji.  
Słowo kodu Huffmana składa się z co najmniej dwóch bitów, żadne ze słów kodu nie składa się tylko z jedynek.  
Słowa kodu odpowiadają kategoriom wartości diff, a nie poszczególnym abs wartościom diff.  
 
Wartość jest liczbą w kodzie binarnym (dwójkowym), reprezentującą znak i wartość (najmniej znaczących bitów)  
liczby dziesiętnej współczynnika diff; 
 dla wartości dodatnich Wartość reprezentuje binarne wartości diff;  
 dla wartości ujemnych Wartość jest reprezentowana binarnie przez dołączenie najmniej znaczących bitów w 

zapisie uzupełnień do dwóch liczby (diff – 1).  
Bity reprezentujące wartość dodatnią diff zaczynają się od 1, a reprezentujące wartości ujemne od 0 i nie ma potrzeby 
dołączania dodatkowego bitu wskazującego na znak liczby, gdyż jest on częścią reprezentacji wartości diff. 
Przykłady: 
Liczba 1310 jest równa liczbie binarnej 11012,   
Liczbie dodatniej 12 odpowiada w kodzie binarnym zapis 1100, natomiast liczba -12 w zapisie uzupełnień do dwóch 
(diff – 1) = (-12-1) = - 13 to 11111110011, ale cztery najmniej znaczące bity tej liczby, to 0011.  
Trik: w przypadku liczb ujemnych zapisujemy ich negację z zapisu wartości dodatnich. 
 
Z tablicy SSSS wynika, że liczbie -35 odpowiada kategoria 6. Kod binarny 35 jest 100011, jego odwrotnością jest 
kod 011100, to znaczy że liczbie -35 odpowiada kod DPCM {6, 011100}. Słowo kodu Huffmana dla indeksu 6 jest 
1110, stąd -35 zakodujemy 10 bitowym słowem kodowym 1110011100. 
 
Liczba 7 w kodzie binarnym ma zapis 111, natomiast w zapisie uzupełnień do dwóch, cztery najmniej znaczące bity 
liczby -7 to 000. 

 
Wg: ISO/IEC 10918-1 : 1993(E) Table F.1 – Difference magnitude categories for DC coding 
ISO/IEC 10918-1 : 1993(E) Table F.2 – Categories assigned to coefficient values AC (str 89) 



Uzasadnienie: większość wartości będzie bliskich zeru 

 
Wartości DPCM dla  Luminancji 

 
ISO/IEC 10918-1 : 1993(E Table K.3  

Tabela VLC Huffmana dla luminancji różnic współczynników DC  
W przypadku kodowania bloków chrominancje korzystamy z poniższej tabeli: 



 
ISO/IEC 10918-1 : 1993(E)- Table K.4 

Tabela VLC Huffmana dla chrominancji różnic współczynników DC  

 
Kod DPCM zakodowany VLC Huffman 

W powyższym przykładzie otrzymaliśmy bity kodu VLC dla poszczególnych kategorii i wartości diff. Najdłuższe jest 
7 bitowe słowo kodowe 1011101.  
Widać, że podział wartości diff na kategorie umożliwia osiągnięcie dużej kompresji.  
Ponieważ małym wartościom diff odpowiadają krótkie słowa kodu, o wiele krótsze niż 11 bitów używanych 
poprzednio do kodowania współczynników AC i wartości DC.  
W naszym przykładzie mamy diff-y 6-ciu kolejnych bloków DC zakodowanych w następujący ciąg bitów: 

101110100011000101000100; 
składa się on z 24 bitów, czyli mniej niż 11 * 6 = 66 bitów potrzebnych do zakodowania nieskwantowanych 
współczynników DC (bez kompresji) 
lub 8 * 6 = 48 bitów jakie były by potrzebne na zakodowanie 6 skwantowanych współczynników DC. 
Jeśli piksele powtarzają się długimi fragmentami, to można osiągnąć prawie 64-krotną redukcję, gdyż w najlepszym 
razie zamiast 128 bajtów wstawiamy 2 - znacznik oraz wartość. 
 

Kompresja składowych zmiennych transformat – elementów AC 
Proces kodowania elementów AC, można podzielić na dwie fazy.  



 W fazie pierwszej ciąg współczynników uzyskany po kwantyzacji i uporządkowaniu zygzak, jest dzielony 
na sekwencje zer zakończonych elementem niezerowym za pomocą kodowania RLE – (run length 
encoding – kodowanie długości serii).  

 W fazie drugiej koduje się te sekwencje przy wykorzystaniu kodowania ze słowem o zmiennej długości 
VLC (ang. variable length coding). Najpierw koduje się metodą Huffmana zintegrowane obiekty typu: 
długość sekwencji zer, liczba bitów w kodzie VLC elementu niezerowego. Następnie koduje się wartości 
niezerowych elementów AC. 
W algorytmie stosujemy tablice kodowe Huffmana, które podano w opisie standardu JPEG ISO/IEC 10918-
1 : 1993(E). 

 
Zgodnie z w/w normą długie ciągi zer w ZZ są kodowane za pomocą metody RLE. 
Kod prefiksowy służący do kodowania długości serii zer tworzy bajt w postaci: 

RS = binarny RRRRSSSS 
w którym 4 najmniej znaczące bity LSB  (Least Significant Bit) SSSS (od Size rozmiar) - są kategorią niezerowych 
współczynników AC - ilość bitów potrzebna do zakodowania ACi.  
natomiast 4 najbardziej znaczące bity MSB (Most Significant Bit) RRRR (od Run-length liczba powtórzeń) 
definiują długość ciągu zer pomiędzy współczynnikiem 

ACi i poprzednim niezerowym ACi-1, 
W celu określenia kategorii AC – SSSS - stosujemy tablicę identyczną jak dla DC (dla bazowego JPEG - ale 
pomijamy wiersz pierwszy i ostatni - mamy 10 kategorii AC).  
Stosuje się dwa specjalne symbole. 
Pierwszym specjalnym symbolem jest ZRL (zero run length), używany wówczas, gdy ciąg zer składa się z więcej 
niż 15 zer; wtedy bajt RRRRSSSS równa się liczbie binarnej 11110000, oznaczającej 16 zer (w tablicy w zapisie 
szesnastkowym oznaczone jako F/0 = 15 zer + 0 = 16 zer). 
Następnym specjalnym symbolem jest EOB (end-of-block), oznaczający same zera za ostatnią zakodowaną 
wartością (koniec bloku, dalej same zera); symbolu EOB nie włącza się do ciągu słów kodu, gdy ostatni 63 
współczynnik ZZ jest różny od zera, wtedy bajt RRRRSSSS jest równy liczbie binarnej 00000000. 
 
Przykład: mamy np. ciąg 63 współczynników AC 

6,7,0,0,0,3,-1,0,0,0,0,0,0,-12,0,…,0. 
Po zastosowaniu kodowania długości serii, otrzymamy współczynniki AC w słowach kodu RLE: 

(0,6),(0,7),(3,3),(0,-1),(6,-12),(0,0) 
- gdzie np. para (6,-12) oznacza ciąg 6 zer zakończony niezerową liczbą -12; 
- ostatni (0,0) =0/0 (EOB) wskazuje koniec ciągu dla tego bloku. ( współczynniki pozostałych AC wszystkie są 
zerami) 
Ponieważ przy kodowaniu par AC na pierwszy element pary mamy do dyspozycji 4 bity, to jeśli występuje więcej 
zer niż 15 np. 22, kodujemy parę jako dwie pary: (15,0)=15 zer + 0 = 16 zer i (6, ACi) = ciąg 6 zer zakończony 
niezerową liczbą ACi.  
 
Słowo kodu RRRRSSSS oznaczające dany ciąg zer nie jest dalej przesyłane. Używamy go podobnie jak przy 
kodowaniu DC jako indeksu umożliwiającego odszukanie w tabeli VLC Huffmana słowa kodu dla każdej pary 
RRRR/SSSS. Dla systemu bazowego JPEG mamy 4 tabele, skrócony przykład pierwszej poniżej. 
Podobnie jak dla DC mamy możliwość jednoznacznego kodowania również współczynników AC, dokonuje się tego 
w ten sam sposób jak w przypadku kodowania diff. 
Mianowicie do słowa kodu VLC Huffmana odpowiadającego bajtowi RRRRSSSS dołącza się dodatkowe bity 
kodujące znak i wartość niezerowego współczynnika AC występującego po ciągu zer. 
Dodatkowe bity są liczbą w kodzie binarnym (dwójkowym), reprezentującą znak i wartość (najmniej znaczących 
bitów)  liczby dziesiętnej współczynnika AC; 
 dla wartości dodatnich Wartość reprezentuje najmniej znaczące bity współczynnika AC;  
 dla wartości ujemnych Wartość jest reprezentowana przez dołączenie najmniej znaczących bitów w zapisie 

uzupełnień do dwóch (w skrócie - U2) liczby (współczynnik AC – 1).  
Przykłady: 

1. słowo kodu RLE (2,-4), ilość zer 2; dla (- 4) w tabeli kategorii znajdujemy, że to kategoria 3; 
RRRR/SSSS = 2/3; w tabeli VLS Huffmana szukamy słowa kodu dla 2/3 mamy: 1111110111; 
kodujemy drugi element pary, liczbę - 4: liczbie dziesiętnej 4 odpowiada liczba binarna 100, ponieważ 
mamy współczynnik o wartości ujemnej, zapisujemy zanegowaną reprezentację binarną liczby 4, czyli 
011. 

2. słowo kodu RLE (0,7), ilość zer 0; dla liczby 7 w tabeli kategorii, znajdujemy że to kategoria 3 RRRR/SSSS 
= 0/3; w tabeli VLS Huffmana szukamy słowa kodu dla 0/3, mamy: 100;  
teraz szukamy wartość binarną niezerowego współczynnika 7 jest to 111. 

3. Słowo kodu RLE (7,-12), ilość zer 7; dla (- 12) w tabeli kategorii znajdujemy, że to kategoria 4; 
RRRR/SSSS = 7/4; w tabeli VLS Huffmana dla 7/4 mamy słowo kodu: 1111111110101111   
kodujemy drugi element pary, liczbę -12: liczbie dziesiętnej 12 odpowiada liczba binarna 1100, ponieważ 
mamy współczynnik o wartości ujemnej, zapisujemy zanegowaną reprezentację binarną liczby 12, czyli 
0011. 



4. słowo kodu RLE (0,50) RRRR/SSSS = 0/6 kodujemy jako: z tabeli 1111000; + 5010 = 1100102 
5. słowo kodu RLE (0,20) RRRR/SSSS = 0/5 kodujemy jako: z tabeli 11010; + 2010 = 101002 
6. Gdy mamy podciąg 0000000000000000 słowo kodu RLE  RRRR/SSSS = 15/0 (ZRL) szukamy w tabeli 

słowa kodu VLS Huffmana – mamy: 

 
 Dodatkowe bity – brak 
Przypomnienie: 

 
 

 
 

 
 



Tablica K.5   VLC dla współczynników AC luminancji 

 
ISO/IEC 10918-1 : 1993(E) -Table K.5 – Table for luminance AC coefficients (sheet 1 of 4) 

 
Jakie osiągamy przykładowe efekty poprzez zastosowanie kodowania VLS współczynników AC?   
 
Powyżej mieliśmy przykładowy ciąg współczynników: 
ZZ[1…63]=[…0,0,-4,0,7,0,0,0,3,0,-1,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0] czyli 31 współczynników 
 
Otrzymaliśmy ciąg = 1111110111011100111111110111110001010 składający się z - 37 bitów (po VLS 
Huffman`a), czyli mniej niż 11 bit * 31 (współczynników) = 341 bitów potrzebnych do zakodowania tej ilości 
nieskwantowanych współczynników AC (bez kompresji); 
lub 8 bit *31 = 248 bitów jakie były by potrzebne na zakodowanie skwantowanych współczynników AC. 
Im mniej niezerowych wartości AC i powtarzających się ciągów zer tym większy stopień kompresji:  
stopień kompresji CR (compression ratio).  

compressedoriginal BBCR :
 

  procent kompresji CP (compression percentage). 

%100
1

1 









CR
CP

 
Rezultatem całego procesu jest plik wynikowy ze skompresowanym obrazem, w którym każda klatka jest 
klatką kluczową, co pozwala na łatwą edycję takiego pliku (proces dekompresji takich danych przebiega w 
odwrotnym kierunku do opisanego powyżej). 
 
Pamiętajmy: Nakręcony film w aparacie, przydaje się zwłaszcza, gdy ma mieć funkcję czysto dokumentacyjną!. 
 

 
 
 
 
 
 
 
 
 
 



 

SP-570UZ  
Film z SP-570UZ w dobrej rozdzielczości VGA 640 x 480 pikseli; 30 klatek/s i karcie pamięci  xD typ standard lub 
M, może trwać max 40 s. Dłuższe klipy mogą być kręcone tylko przy zastosowaniu xD typ M+:  

 
Założono, że nośnik pamięci został świeżo sformatowany 

1. Wszystkie czasy są przybliżone i są obliczone w oparciu o pojemność pamięci, i nie są one gwarancję 
czasu pracy baterii akumulatorów. 

2.  Maksymalna długość dla filmu VGA/30fps podczas fotografowania przy użyciu xD-Picture Card 
standardowych lub Type M wynosi 40 sekund. 

3. Korzystanie z dowolnej wielkości karty typu xD-Picture Card, maksymalna długość filmu jest 29 minut   
 Karty  xD-Picture card Typ M+ są kompatybilne do wszystkich aparatów, są 1,5x szybsze od Typu M. 
W ustawieniach dla najlepszej jakości, SP570UZ może zarejestrować filmy z rozdzielczością VGA (640 x 480 
piksli) i szybkością 30 klatek. Zarejestrowanie szybko tyle danych, wymaga dużej ilość pamięci aparatu (mamy 
48MB)  i bardzo szybkiego czasu zapisu. 
Karty Olympusa xD Typ M+  - są szybkimi kartami i są w stanie, przetworzyć ten wolumen informacji bez straty 
jakości. Inne komercyjnie dostępne, standardowe typowe xD Typ M, nie są zdolne, zrobić tego.   
Z tego powodu, rejestracja filmu VGA w trybie 30 fps w SP570UZ ograniczona jest do 40 sekund, kiedy używamy 
kart innych niż Typ M +. Ograniczenia 40sek gwarancje, że aparat fotograficzny jest w stanie, przetworzyć dane 
właściwie i tworzy gładki, bezbłędny film podczas playbacku. 
Uwaga: w zredukowanej rozdzielczości i szybkości 320 x 240 pikseli, 15 klatek/s; możemy nagrać do 29 min filmu.  
 
Pamiętamy,  
aby kartę formatować tylko w aparacie, xD nie posiadają własnego kontrolera. Formatowanie w PC i w aparacie to 
niby to samo - standardowe nadpisanie FAT - ale jednak aparat może inaczej rozumieć "standard". 
Formatowanie karty xD za pomocą czytnika , może doprowadzić do błędów zapisu w aparacie, spowodowanych 
innym napięciem formatującym i różnicą w kontrolerach czytnika i aparatu. Związane jest to z tym, że istnieje kilka 
formatów dla nośników danych (FAT12/FAT16/FAT32/NTFS/....). Aparat obsługuje jeden konkretny, PC kilka. 
Formatowania karty nie usuwa z niej danych, modyfikuje się jedynie tablice alokacji plików FAT, czyli informacje o 
tym co i gdzie znajduje się na karcie, reszta pamięci flash nie jest ruszana. Oprogramowanie aparatu traktuje taką 
kartę jako "pustą" i nadpisuje dane. Logicznym jest, że im większa pojemność karty, tym więcej zapisów w FAT i 
dłuższy czas tworzenia nowego, podczas procesu formatowania.  
Podczas wkładania i wyjmowania karty nie dotykamy styków palcami! (lub przedmiotami metalowymi), ponieważ 
wyładowanie elektrostatyczne może zniszczyć kartę!!.  
ESD (ElectoStatic Discharge) – wyładowanie elektrostatyczne jest to gwałtowne wyrównywanie się potencjałów 
elektrycznych, któremu towarzyszy duży impuls prądowy, często powiązany z przeskokiem iskry. 
Czy człowiek może być zagrożeniem dla układów scalonych (urządzeń elektronicznych)? Tak, powodem jest  
nieustanne ładowanie się ciała ludzkiego w czasie wykonywania dowolnych czynności (chodzenie, zakładania i 
zdejmowanie ubrania itp.), dodatkowo sprzyja temu wszechobecność tworzyw sztucznych!. 

W tabelce podano kilka przykładowych poziomów naładowania w różnych sytuacjach: 

CZYNNOŚĆ 
WILGOTNOŚĆ WZGLĘDNA 

10% 55% 

Chodzenie po dywanie 35000 V 15000 V 

Wyjmowanie płytki z opakowania z tworzywa sztucznego 26000 V 7000 V 

Wyjmowanie układu z podstawki 11500 V 400 V 

  
Chcąc oczyścić styki karty stosujemy suchą miękką tkaninę (nie elektryzującą się). Nie stosujemy spirytusu!!. Nie 
odłączamy i podłączamy karty pod napięciem oraz w trakcie odczytu i zapisu danych. 
 
 
W naszych aparatach, obiektyw nie ma skali odległości, ale wstępne ustawienie długości ogniskowej "z grubsza" 
jest możliwe.   
Aby wszystko było zrozumiałe - omówię po kolei. 
Jeśli chcemy filmować przy ustalonej wartości ogniskowej możemy postępować zgodnie z zasadą jaką podałem 



już kiedyś w swoim poradniku: Zbyma_Systemy_ustawiania_ostrości_SP570UZ.pdf  
Wobec braku, skali pokazującej aktualną ogniskową, możemy skorzystać z następującej metody ustalenia 
potrzebnej ogniskowej: 
- zmieniając ogniskową przy przysłoniętym obiektywie (tylko w trybach P, A przy włączonej lampie błyskowej 
wybrać tryb pracy lampy „AUTO lub ”) - przy ogniskowej EFL= 50mm, na wyświetlaczu czas ustawia się na 
1/50s, a przy ogniskowej 100mm, czas ustawia się na 1/100s ponieważ dla takiej właśnie ogniskowej ten czas jest 
wartością "bezpieczną" (zgodnie z zasadą mówiąca, że zdjęcie powinno wyjść nieporuszone, jeśli czas otwarcia 
migawki będzie co najmniej równy, a najlepiej krótszy, niż odwrotność ogniskowej obiektywu.)  Również przy 
wartościach pośrednich, czasy odpowiednio się dopasowują.  
Nie jest to metoda dokładna, ale na bezrybiu i rak ryba! 
 
Mając ustaloną wartość długości ogniskowej, nie wyłączając aparatu, przełączamy go za pomocą Pokrętła nastaw 

trybów fotografowania na -  tryb Rejestrowania Sekwencji wideo, przyciskiem MENU wchodzimy do Menu 
głównego i przy pomocy klawiszy strzałek (Joysticka) ustawiamy na MENU APARATU -> OK. i otwiera się okno  

 
 

Jakie parametry możemy ustawiać przy rejestrowaniu sekwencji wideo: 

 podczas rejestracji sekwencji wideo możemy w SP-570UZ włączyć podgląd poprzez 

Elektroniczny wizjer EVF przyciskiem Quick View  . Jest to szczególnie korzystne w warunkach silnego 
otaczającego oświetlenia słonecznego. Nie występuje tu błąd paralaksy, obraz widziany przez fotografującego 
odpowiada w 97% temu, co zostanie utrwalone na matrycy, możliwość korekcji wady wzroku: - 2,5 do + 1,5 dioptrii. 
Obraz prezentowany w wizjerze nie pochodzi bezpośrednio z obiektywu, ale jest przekazywany z matrycy. Użycie 
zalecane również, ze względu na oszczędność energii akumulatorków. Jest to również dodatkowy punkt podparcia 
o oczodół przy filmowaniu z ręki. 
 
W trybie filmowania, aby mieć możliwość ostrzenia i posługiwania się zoomem, należy wyłączyć mikrofon.  
W przeciwnym razie do dyspozycji mamy wyłącznie zoom cyfrowy, który mimo dużej rozdzielczości matrycy 
pogarsza jednak jakość obrazu (rozdzielczość obrazu VGA 640x480 pilseli to tylko ~ 0,3Mpix). 
WB Balans Bieli 
 - Auto, aparat na bieżąco analizuje składowe barwne i na tej podstawie, płynnie ustawia balans bieli. Gdyby 
działało bezbłędnie, w każdych okolicznościach, poniższych opcji by nie wprowadzono. 
 - Ustawione tryby predefiniowane (Słońce, Pochmurno, Światło żarówkowe, Świetlówka 1,2,3), zawierają 
możliwość wyboru oświetlenia: słońce, chmury, żarówka (ok.3000K), świetlówka1 - domowa (ok. 6700K), 
świetlówka2 - biurkowa(ok. 5000K), świetlówka3 - biurowa(ok. 4200K). Ten tryb wyboru sprawdza się w praktyce. 
Odpowiednio należy dobrać ustawienie do panujących warunków oświetleniowych, aby otrzymać realistyczną 
barwę. Przy czym dla każdego trybu możemy jeszcze zastosować korekcją balansu bieli – opis poniżej. 

- Własny,  - pozwala ręcznie osiągnąć jeszcze lepsze rezultaty - wykalibrować balans bieli.  
Będąc w tej opcji, klikamy kursor w prawo, a ukaże się ekran z napisem - "WB z pomiarem własnym". 
W tym momencie, całe pole tego ekranu, musimy wypełnić jakąś białą płaszczyzną. Może to być kawałek białej 
kartki papieru foto (powinna być matowa), który zawsze powinniśmy mieć przy sobie kierujemy na niego 
obiektyw, tak aby powierzchnia kartki wypełniła cały kadr (sprawdzając jednocześnie, czy nie ma żadnych cieni, w 
ostateczności może być to biała ściana, czy też nawet śnieg), przy czym staramy się ją lekko niedoświetlić, dlatego 

fotografujemy biały kartonik z korektą ekspozycji ustawioną na np. -1. Nie gra roli czy światło jest bezpośrednie, 
odbite, ostre czy zmiękczone (np. przez chmury) - kartkę musimy zawsze trzymać równolegle do powierzchni 
matrycy.   



Naciskając teraz przycisk "OK" sprawiamy, że elektronika aparatu "dowie się", co uważamy za naprawdę białe i 
podług tego będzie ustalać inne kolory.  
 
Sprawdza się to znakomicie w trudnych barwnie warunkach, np. pokój oświetlony równocześnie żarówką i 
świetlówką, czy nietypowym świetle np. lamp sodowych (źródła światła o różnej temp. barwowej - innym widmie) 
gdzie automatyczny balans głupieje, a i My nie wiemy na pewno, w którym kierunku się skłonić.   
Jak jednak próbkować jedno (np. główne) źródło tak, by pozostawić innym wpływ na kolorystykę? Próbkowanie na 
biały kartonik da nam balans uśredniony dla wszystkich źródeł światła i to uśredniony dla tego tylko miejsca gdzie 
umieścimy kartkę. Jak sobie poradzić z tym problemem?  
Zastosujemy zasłonięcie obiektywu białą kartką i skierowanie na źródło światła w celu ustalania prawidłowej 
ekspozycji światła padającego, lub lepiej, na obiektyw aparatu nałożyć (przyłożyć), kawałek białego cienkiego 
plastiku np. dno kubka po serku Almette, a następnie obiektyw z tak zrobionym „dyfuzorem” skierować wprost na 
próbkowane źródło światła. Dalej postępujemy jak przy próbkowaniu na biały kartonik. W ten sposób otrzymamy 
zbalansowanie bieli dla wybranego źródła światła.  
 
Jest to tylko korekta koloru, czyli stosunku zawartości R do G i do B, a nie korekta poziomu jasności bieli, którym 
zajmuje się pomiar ekspozycji. 
Procedura obliczania balansu bieli jest prosta - aparat wiedząc, że kartka powinna być biała, sprowadza RGB do 
jednakowych wartości i różnicę wykorzystuje następnie do korekcji kanałów RGB w wykonywanych zdjęciach.  
Problem tylko w tym, żeby podczas fotografowania białej kartki (kartonika) żaden z kanałów RGB nie osiągnął 
maksymalnej wartości (dla 8 bit - 255). Po prostu należy fotografować białą kartkę, tak aby biel była 
niedoświetlona (czyli z najpierw ustawioną korektą ekspozycji na -1 do –2).  
Pamiętamy również:  
Szara kartka TYLKO tym różni się od białej, że odbija mniej światła, nie zmieniając jego składu spektralnego. 
 
Inny aspekt związany z balansem bieli:  
w dużej części filmów (zdjęć) biel nie powinna być dokładnie zbalansowana, ponieważ każde światło ma swój 
specyficzny kolor, odchyłkę od bieli, co daje nastrój. Zdjęcie czy film przy zachodzącym słońcu czy ognisku  
powinny być ciepłe, pomarańczowe, nocne w świetle księżyca lekko niebieskie, w domu przy żarówkach czy 
świecach - także lekko pomarańczowe. To tworzy klimat. Usunięcie tych dominant spowoduje zubożenie ujęć. 
Poza tym oczywiście wiele zależy od zamierzonego efektu. Przykład to np. filmowanie w pochmurny dzień przy 
opadach deszczu. Temperatura barwowa na zewnątrz jest wtedy bardzo wysoka. Gdy zbalansujemy do niej 
kamerę, otrzymam ciepłe, nasycone kolory. Czy tak wygląda ten ponury dzień? Bardziej naturalne wrażenie 
wywoła film przy niższym balansie powiedzmy 5500K. Kolory będzie blade, z słabą dominantą niebieskiego, ale 
lepiej to odzwierciedli panującą wtedy aurę.  
 
Filmy nocne, również nie są  tajemniczą sztuką tylko dla wtajemniczonych. Obowiązują tu takie same zasady, jak 
przy świetle dziennym, trzeba tylko wiedzieć, co mierzyć. Jeśli jest to jasno oświetlony pasaż, wystarczy dokonać 
pomiaru na jakąś jasną powierzchnię, unikając jednocześnie świateł latarni. Gorzej, gdy w kadrze jest dużo 
ciemnego z jasnymi punktami światła, wówczas praktycznie trzeba zawsze pomiar matrycowy skorygować na 
minus tzn. korekcja ekspozycji od -1EV do nawet -2EV, w zależności od tego, jak dużo czerni jest w centrum kadru. 
Pomocny się tu staje pomiar punktowy, wystarczy "podjechać" zoomem, zmierzyć np. średnio oświetloną ścianę, 
zapamiętać pomiar, "odjechać" i rozpocząć filmowanie. 
Jeśli dopiero zaczynamy filmowanie ujęć nocnych i ciągle dręczą Nas dylematy - co tu mierzyć, na  ile niedoświetlić 
itp., istnieje prosty i sprawdzony rodzaj pomiaru nocnych pejzaży. Wystarczy znowu kawałek białej kartki 
matowego papieru foto (lub w ostateczności dłoń). Odwracamy się plecami do filmowanej sceny, kartkę 
trzymamy przed sobą w wyciągniętej ręce, kierujemy na niego obiektyw, tak aby powierzchnia kartki (dłoni) 
wypełniła cały kadr (sprawdzając jednocześnie, czy nie ma żadnych cieni) i zapamiętujemy.  Następnie 
wprowadzamy korekcję ekspozycji +2 EV.  Ten rodzaj pomiaru fachowo zwie się - pomiarem światła odbitego.  
Z braku kartonu, można w ten sam sposób wykorzystać własną dłoń, z tą różnicą, że wówczas zwiększamy 
ekspozycję od +1,5EV. Przy pomiarze należy uważać, aby swą osobą, czy też obiektywem, nie rzucić cienia na 
mierzony karton, czy też dłoń. 
 http://artykuly.filmowiec.pl/artykul.php?aid=41 Podstawowe zasady ustalania poziomu bieli 
 
Światło jest kapryśne i czasem płata figle. Nierzadko fotografujemy w sytuacjach, w których źródeł światła jest kilka 
(np. dzienne, żarowe i jarzeniowe – mówimy wtedy o świetle mieszanym), często o temperaturze barwowej z 
krańców skali, przez co po prostu nie da się zrobić zdjęcia o neutralnych barwach. Czasami można wyodrębnić 
główne, najmocniejsze źródło światła – wtedy ustawiamy balans bieli z myślą o nim. 
 
Dalsze pare amatorskich metod:  
- w pomieszczeniach, oświetlonych lampami żarowymi, świetlówkami, halogenem itp, a zwłaszcza gdy ściany są w 
intensywnych kolorach, lub tam, gdzie nie ma czasu na ceregiele, szukamy czegoś białego (obrus, suknia itp.) i na 

pełnym zoomie dokonujemy korekcji .  
- Przy zdjęciach ulicznych, oświetlonych w nocy lampami o różnej temperaturze barwowej, podchodzę do latarni i 
ustalam manualny balans na kartkę białego lub szarego papieru. Podobnie czynię przy ognisku, choć czasem 

http://artykuly.filmowiec.pl/artykul.php?aid=41


lepiej zostawić malownicze oświetlenie bez korekcji.  
- Przy sesjach plenerowych o zachodzie lub wschodzie słońca dokonuję ręcznego balansu na szary kartonik, z 20-
to procentową szarością, jaki sam wydrukowałem ze świadomością, że nie jest to szarość idealna. Odniesienie do 
szarości wydaje się dla mojej kamery lepsze od tła białego, gdyż biel zbytnio wydobywa niebieskości.  
- W mojej starej kamerce analogowej balans wykonywałem za pomocą mlecznego dekielka, nasadzanego na 
obiektyw w dwojakiej roli (ochrona soczewki i WB). Po wybraniu opcji manualnego balansu nasadzało się dekielek 
na obiektyw, przesuwało zoom na max (eliminacja widoku struktury dekielka) i po skierowaniu kamery na 
filmowany plan – zatwierdzało ręczny WB. Mimo tej prostoty, wyniki były pozytywne.  

Wideo z dźwiękiem : 
-  mikrofon jest domyślnie wyłączony (także w trybie kręcenia wideo), możemy go włączyć w Menu Aparatu. 
Dźwięk zintegrowany z AVI, format WAV – ośmiobitowy dźwięk mono (PCM, częstotliwością próbkowania 8 kHz, 
rozdzielczość 8 bitów na próbkę, CBR (ang. constant bit rate) - Stała przepływność = 64kb/s najpopularniejsza 
metoda reprezentacji sygnału analogowego w systemach cyfrowych, jakość słaba. 
– gdy wybierzemy opcję wideo z dźwiękiem, nie można używać zoomu optycznego. Można wtedy ewentualnie 
używać zoomu cyfrowego (do 5x), który uaktywnić można dopiero po rozpoczęciu filmowania (uwagi na jego temat 
poniżej). Zoomu cyfrowego używamy, jeśli maksymalne zbliżenie jest ważniejsze niż jakość obrazu. 
- gdy wybierzemy opcję wideo z dźwiękiem, nie działa funkcja cyfrowej stabilizacji obrazu (wyszarzona w 
menu).  
- jeśli włączymy (Wł) funkcje: CIĄGŁY AF (ciągły pomiar ostrości) i wideo z dźwiękiem, na filmie będzie nagrany 
dźwięk pracującego mechanizmu obiektywu (takie klekotanie). 
Zoom optyczny – tylko przy wyłączonej opcji wideo z dźwiękiem.  
Stabilizacja obrazu – po włączeniu, ciągłe nagrywanie filmu, przez dłuższy czas powoduje wzrost temp. wew. 
aparatu. W rezultacie aparat może się wyłączyć, związane to jest z wbudowanymi w aparat zabezpieczeniami 
termicznymi. Monitorują one temperaturę przetwornika obrazu i przerywają jego prace, gdy osiągnie ona 
niebezpieczny poziom. Jeśli tak się stanie, wtedy przed ponownym włączenie należy wyjąć baterie i pozwolić 
aparatowi ostygnąć.  
Jak wynika z tego, przy niskiej temperaturze otoczenia długość pojedynczej sekwencji może być dłuższa, ale czas 
kolejnych rejestracji następujących bezpośrednio po sobie może też być krótszy.  
( Innym ograniczeniem czasu rejestracji są 2 GB objętości pliku z nagranym materiałem (wynika to z maksymalnej 
wielkości pliku w systemie FAT32). 
Jeśli stosujemy statyw – funkcję stabilizacji obrazu należy wyłączyć!.  
Pomiar światła - jasności obiektu  
Pomiarowi światła w SP-570UZ nie można nic zarzucić.  
Światłomierz, każdego aparatu wykalibrowany jest na tzw. przeciętną szarość, odbijającą 18 procent światła. 
Skutkuje to tym, że każdy motyw zostanie zarejestrowany na filmie, jako przeciętnie szary, nieważne czy będzie to 
czarny kot na węglu, czy też biały kot na śniegu. 
Oznacza to, że bez względu na tonalność płaszczyzny, z której dokonywany jest pomiar, prawidłowo naświetlony 
klip powien ona wyjść na szaro, czyli mierzy tonalność identyczną ze standardem tzw. Szarej Karty. 
Jeśli więc sfilmujemy białą kartkę, następnie czarną i wreszcie szarą otrzymamy na klipie szare, biel stanie się 
ciemniejsza, czyli niedoświetlona, czerń jaśniejsza, czyli prześwietlona. 
Wynika z tego, że aby każdy film był poprawnie naświetlony należy - niedoświetlić cienie i zarazem prześwietlić 
światła. 
• wielosegmentowy ESP - przeważnie możemy się zdać na pomiar matrycowy. Wystarczy tylko stwierdzić, że w 
fotografowanej (Filmowanej) scenie nie ma dużych obszarów w cieniu i jednocześnie takich, które oświetlone są 
mocnym słońcem, sporych fragmentów śniegu, słowem – motywów wyjątkowo ciemnych i/lub jasnych. 
• centralnie ważony (Center-weighted) Przy pomiarze centralnie ważonym najważniejszy jest motyw znajdujący 
się w centrum kadru. To do jego jasności aparat dobiera czas i przysłonę. Gdy go używamy, aparat mierzy osobno 
jasność centralnej części kadru i jego brzegów. W ostatecznym pomiarze centrum zdjęcia ma większą wagę (np. 
60%), a tło mniejszą. Na tej podstawie ustalana jest odpowiednia kombinacja przysłony oraz czasu. Jeśli na 
zdjęciu dominuje czerń lub biel, wychodzą one szare.  W takim przypadku pomóc może wyłącznie ręczna korekta 

ustawienia jasności. Do tego celu aparat oferuje osobny przycisk oznaczony .  

• punktowy (Spot)   Przy punktowym trybie mierzone jest tylko światło odbite od małego, wybranego obszaru 
obrazu. Funkcja ta jest przydatna zwłaszcza przy bardzo kontrastowych motywach, gdy chcemy poprawnie 
naświetlić określony punktu kadru. 
Kompensacja balansu bieli  

 

http://pl.wikipedia.org/wiki/Kiloherc


 - korekcja balansu bieli, jest trybem pozwalającym na dostrojenie balansu bieli i zniwelowanie lub 
wprowadzenie dominanty koloru. Opcja koryguje 7 stopniowo balans bieli w dwóch kierunkach w stronę Niebieski 
(ochładza kolorystykę obrazu) oraz w stronę Czerwony (ociepla kolorystykę obrazu). 
Funkcja pozwala nam dostroić ustawienia profili predefiniowanych oraz Własnego WB do swoich upodobań. 
Najbardziej istotna jest możliwość obserwacji obrazu na żywo na ekranie LCD, na którym widzimy wpływ 
zmienianych parametrów na balans bieli. 
Ostrość - ±5 regulacja poziomu ostrości pomiędzy + 5 a - 5.  
Ta funkcja działa w sposób cyfrowy - ale jeszcze przed kompresją!!. Ta funkcja jest bardzo dobra: jako pierwszą 
rzecz włączamy regulację ostrości. Maksymalny poziom ostrości S+5 zauważalnie polepszy rozróżnianie drobnych 
szczegółów i wrażenie całkowitej ostrości ujęcia. Podobnie jak w przypadku interpolacji większej rozdzielczości 
zdjęcia, niektórzy twierdzą, że równie dobrze, a nawet lepiej, można to uzyskać później np. w VirtualDub, nie jest to 
prawdą – prędzej i więcej ujawnią się atrybuty kompresji, a nie drobne szczegóły zniszczone kompresją. Ale trochę 
większe będzie ziarno i szumy. Jeśli, natomiast ustawimy wartości ujemne, obraz będzie bardziej "miękki", ale i 
zakłóceń będzie mniej. 
Kontrast - co to jest, każdy wie regulacja pomiędzy + 5 a – 5. 
Nasycenie - reguluje stopień nasycenia kolorów na zdjęciu, pomiędzy + 5 a – 5 bez zmiany odcienia. 
Przy pomocy klawiszy strzałek (Joysticka) ustawiamy: 

Tryb makro (7cm - 60cm)Wide;   (1,2m – 2m)Tele i  

sMakro:  od 1cm -   
Można wykorzystać filmowanie w sMacro w którym ogniskowa  jest zablokowana  na wartości  55mm, czyli mamy 
wtedy obiektyw stało ogniskowy (stałka), który umożliwia fotografowanie z ustawieniem ostrości w zakresie od 1cm 
do  nieskończoności!. Bez optycznego zoomu oraz możliwości używania cyfrowego zoomu (opcja wyszarzona w 
Menu) pamiętamy o małej głębi ostrości. 
Samowyzwalacz – Tak (aparat na statywie, ustawiamy ostrość na jakiś obiekt w miejscu w które chcemy się 
przemieścić, ustawiamy czs na 12s, naciskamy spust i spokojnie wchodzimy w kadr (np. na tle panoramy górskiej 
w trakcie wycieczki itp. :- ). 
Mamy również możliwość regulacji: 

Korygowanie cieni – rozjaśnianie obiektu filmowanego pod światło …. funkcję kompensacji oświetlenia 
tylnego, włączamy ją, kiedy słooce znajduje się za filmowanym obiektem, a chcemy, aby szczegóły znajdujące się 
w cieniu były widoczne. Technologia kompensacji cienia 

Technologia stworzona, by poprawić ekspozycję zdjęcia w jego ciemnych partiach. Wykorzystując sensor 
działający podobnie do ludzkiego oka identyfikowane są ciemne partie kompozycji (np. zacieniony obszar pod 
drzewem) i aparat dobiera odpowiednią ekspozycję dla tych obszarów. W rezultacie powstaje zdjęcie, które jest 
bardziej realistyczne i charakteryzuje się większym bogactwem szczegółów. 

Zmiana jasności obrazu (kompensacja ekspozycji) w zakresie – 2.0 EV do + 2.0 EV 
Służy do korekcji pomiaru światła zastanego. Funkcja ta pozwala na dostrajanie aktualnego ustawienia ekspozycji 

za pomocą: Przycisk  i obrócić pokrętło sterujące  w celu skorygowania, potwierdzić ponownie 

przyciskiem  (przed rozpoczęciem nagrywania). Przy wybraniu wartości dodatnich - ujęcie wyjdzie jaśniejsze, i 
odwrotnie - wartości ujemne, skutkują ciemniejszymi ujęciami. Ekspozycję regulować można co +/- 0.3; 0.7; 1.0; 
1.3; 1.7; 2.0EV. Korekcję ekspozycji należy zastosować, filmując w wieczornym świetle (-1, -2 EV), podczas złej 
pogody (+0.3, +0.7 EV), filmując białe rzeźby na tle białych ścian czy osoby na śniegu (+1, +2 stopnie przysłony).  
Najlepiej na stałe ustawić korekcję ekspozycji na - 0,3 EV tzn. nie doświetlać każde ujęcie, ale przy filmowaniu 
czarnego kota standartowo -1,0, przy zdjęciach na śniegu to nawet i +2.0. 
Aby każdy, klip był poprawnie naświetlony należy – nie doświetlić cienie i, zarazem prześwietlić światła. I ta sama 
zasada obowiązuje, gdy na motywie są same cienie - należy je nie doświetlić, lub też, gdy same światła - należy je 
prześwietlić. 
Nie mamy żadnego wpływu na ustawienia: 
ISO – opcja wyszarzona, nie można manualne ustawiać – ustawiane automatyczne oraz A – przysłona. 
 
Kilka słów o opcji -"DIGITAL ZOOM"  
Symulacja efektu zmiany ogniskowej polegająca na elektronicznym powiększaniu fragmentu obrazu, do pełnego. 
Na internetowych „forach” często się spotykamy z opinią, że można włączyć, ale przy jego zastosowaniu spada 
jakość obrazu - powiększenie cyfrowe obrazu z matrycy będzie gorsze niż byśmy to uzyskali z fotografii nie 
zoom`owanej.  
Perfekcjoniści twierdzą, że: „jakość interpolacji w aparacie nie jest tak wysoka, jaką umożliwiają specjalne 
programy”. Jest to prawda... 
Jest tu jednak jeden ważny problem, który należy wyrazić jednym tchem z poprzednim twierdzeniem – 
ale aparat interpoluje zdjęcie jeszcze za nim zapisze je do formatu JPG.   



Ta drobnostka jest bardzo ważna. Gdy kompresor 
JPG zniszczy niektóre szczegóły, żaden współczesny softwar`e już ich ze zdjęcia nie wydobędzie powtórnie. 
Jednak, gdy te szczegóły aparat zwiększy, choć i mniej jakościowo – przed tym, niż je zniszczymy kompresją JPG, 
są one przenoszone. O nieco mniejszej jakości, jak by to było możliwe teoretycznie, ale są!.  
Zoom cyfrowy stosować będziemy w specyficznych sytuacjach, kiedy bardzo chcemy sfotografować coś 
przestrzennie oddalonego, a nie możemy nijak się zbliżyć, chcemy przy tym na zdjęciu widzieć jak najwięcej 
szczegółów za każdą cenę. Czyli gdy maksymalne zbliżenie jest ważniejsze niż jakość obrazu. 
 
Sprawdzimy powyższe stwierdzenia, korzystając z możliwość zapisywania klatek filmu jako zdjęć: 

Przełączamy Pokrętło nastaw trybów fotografowania na tryb  odtwarzania sekwencji wideo, włączamy aparat. 
Przy pomocy klawiszy strzałek (Joysticka) wybieramy sekwencję wideo, z której chcemy przechwycić pojedynczą 
klatkę jako zdjęcie. Po wyborze sekwencji wideo naciśnięcie przycisku MENU spowoduje wyświetlenie na 
monitorze (lub w celowniku) menu głównego. Teraz przy pomocy klawiszy strzałek (Joysticka) wybieramy pozycję 
EDYCJA -> OK. W menu EDYCJA wybieramy INDEKS FILMU -> OK. Pojawi się okno INDEKS FILMU -> 
USTAW klikamy OK, teraz możemy przy pomocy klawiszy strzałek (Joysticka) wybierać do przechwycenia 
pojedynczą klatkę z sekwencji wideo. Po jej wybraniu zatwierdzamy wybór OK, klatka zostaje zapisana jako 
zdjęcie.  
Oto przykładowe klatki sfilmowanej części tablicy wzorcowej ISO 12233 z ekranu laptopa: 

Włączono Macro, odległość przedmiotowa 90cm, EFL – ekwiwalent na długość ogniskowej 100mm, włącz. ,  
Ciągły AF wył.; użyto statywu. 

 
Bez zoomu cyfrowego – pierwsze klatki 



 
Zoom cyfrowy pośredni 

 
Zoom cyfrowy pośredni 



 
Zoom cyfrowy 5x 

Na pierwszym zdjęciu zaznaczono rejony określania rozdzielczości obrazu. 
Przy max zoom cyfrowym widać efekty kompresji, tracimy na ostrości zdjęcia, ale nie widać aliasingu w postaci 
charakterystycznych "schodków" na krawędziach ukośnych lub krzywych liniach. 
[gdy na matrycę z naprzemiennie ułożonych elementów rzucimy obraz o jednorodnym wzorze pojawia się wzór 
zwany interferencyjnym lub potocznie morą - drobne wzory gęstych naprzemiennych linii ustawione skośnie 
względem matrycy światłoczułej sprawiają, że na obrazie pojawiają się jasne i ciemne pasy, (których w 
rzeczywistości nie ma), gdy poruszamy obiektywem przy ogniskowaniu, na skutek złudzenia optycznego mamy 
wrażenie, że wzór faluje]. 
 
Profesjonalne testy opierają się na dużych planszach wysokiej jakości. Można zajrzeć np. na: 
http://www.delta.poznan.pl/news/cctvopis/cctvop1b.jpg Test jakości obrazu w systemach telewizji przemysłowej 
 
Tips & Tricks - czyli ważne momenty i „podwodne rafy” 
Filmowanie rozpoczniemy i podtrzymamy po pełnym naciśnięciu spustu migawki, ale przedtem musimy określić 
odpowiednią ogniskową i ustalić ostrość – jeśli zoom jak i AF po rozpoczęciu nagrywania nie działają. 
 
Jeśli mamy AF włączone na stałe, będziemy trochę oszukiwani. Ostrzenie niestety nie jest najszybsze, tak więc 
musimy się liczyć z nieostrym obrazem w czasie ok. 1 – 2 sec, aż AF całkowicie wyostrzy. Mechanizm AF w 
aparacie zawsze działa wolniej niż w kamerze filmowej, ponieważ wymaga się od niego większej dokładności. 
Można ocenić szybkość pracy AF, szybko przenosząc aparat z bliskiego obiektu na dalszy i naodwrót. 
Można też ocenić jakość AF w zależności od zastosowanego zooma.  
Jeśli AF zostanie wyłączone, obraz jest stale ostry jeśli wyraźnie nie zmienimy odległości pomiędzy aparatem a 
filmowanym obiektem (nieprzenoszenie kadru na znacznie oddalone od siebie plany).  
Problem rośnie w miarę zwiększania zastosowanej ogniskowej, czy mniejszej odległości przedmiotowej. 
Trudno od aparatu cyfrowego oczekiwać w tym zakresie cudów i musimy przyzwyczaić się także do odczuwalnej 
zmiany otworu względnego (przysłony), objawiającej się skokowym wzrostem ściemnienia/rozjaśnienia obrazu.  

 
Odblaski słońca od błyszczącej powierzchni, wytworzą fioletowe migające paski. 

Jeżeli zastosujemy największą ogniskową , czyli zoomem maksymalnie przybliżymy filmowany obiekt zmniejszymy 
głębię ostrości. Kąt widzenia aparatu zawęża się. Perspektywa zostanie spłaszczona. Tło w kadrze zostanie 
rozmyte. Przedmioty znajdujące się pomiędzy obiektem a aparatem będą nieostre. Filmując obiekty zbliżające się 
do nas (długą ogniskową), możemy "wydłużyć" czas dojścia do kamery.  

http://www.delta.poznan.pl/news/cctvopis/cctvop1b.jpg


Odwrotnie sytuacja będzie wyglądać jeżeli będziemy filmować obiektywem o szerokim kącie (minimalny zoom).  
Kąt widzenia będzie szeroki, głębia ostrości głęboka, czyli tło jak również filmowany obiekty są ostre.  
Ale pamiętamy, że krótka ogniskowa ma tę właściwość, że łatwo deformuje perspektywę.  
 
Pamiętajmy o oszczędnym używaniu zoomu podczas filmowania, zwłaszcza podczas filmowania poruszających się 
obiektów. Nadmierne przybliżanie i oddalanie jest zwane w gwarze filmowców "pompowaniem" i świadczy o 
nieznajomości elementarnych podstaw sztuki operatorskiej. Czasem lepiej jest zmienić pozycję niż powiększać czy 
zmniejszać obiekt. 
W przypadku bardzo dużych zbliżeń unikamy zamazanych ujęć, stabilizując kamerę np. przez użycie statywu lub 
rezygnując z dźwięku zastosujemy zarówno stabilizację aparatu jak i AF. 
Przy wyłączonej stabilizacji, ewentualne drgania aparatu w trakcie filmowania nie są groźne dla jakości filmu, 
ponieważ co ok. 1/30 sekundy mamy nowe zdjęcie. Natomiast problemem może być widoczne "skakanie" obrazu. 
Jeżeli np. w trakcie filmowania aparat drga w kierunku pionowym, to choć kolejne klatki będą ostre, to np. tocząca 
się po boisku piłka będzie rejestrowana w coraz to innym miejscu (w kierunku pionowym) matrycy. Musimy 
zastosować statyw. 
 
Pewną niedogodnością jest ograniczenie regulacji ekspozycji – możemy wymusić niedoświetlenie do -2EV, 
symulacja prześwietlenia obejmuje do 2 EV.  
  
Najmniejszą chyba niedogodnością jest niemożność wpływania na parametry ekspozycji w trakcie filmowania: nie 
możemy regulować otworu przysłony, czułość przetwornika, skazani jesteśmy na kombinację, którą dobierze 
automatyka aparatu.  
 
Co się tyczy regulacji ogniskowej – każdy "lustrzankowy" obiektyw przewyższa o niebo pod tym względem 
"szarpany", elektryczny zoom naszych aparatów (nie może się równać np. z obiektywem specjalnie 
zaprojektowanym do filmowania w aparacie Panasonic DMC-GH1, gdzie zastosowano wyciszony autofokus 
minimalizujący mechaniczne dźwięki powstające podczas jego działania). 
 
Filmy w formacie AVI kodowane algorytmem Motion JPEG, znakomicie nadają się do późniejszego montażu.  
Czyli, nie bójmy się filmować, bo potem możemy przeglądać materiał, kroić, kleić i montować. 
 
Aparat po ustawieniu ostrości, ostrzy chyba na zasadzie odległości hiperfokalnej. 
Jedyne na co mamy wpływ to odległość z jakiej filmujemy (moment naciśnięcia przycisku migawki fiksuje odległość 
ostrzenia). Ponieważ czas naświetlania jest stały, automatyka może tylko reagować przysłoną i ISO. 
 
Jakość dźwięku  
Jakość dźwięku w SP-570UZ, cierpi na te same ograniczenia jak większość jego rówieśników - mały przeciętny 
mikrofon  

 
wbudowany w korpus aparatu po  lewej górnej stronie obiektywu, przenosi również dźwięk rąk, przesuwających się 
dookoła po korpusie, słychać chrobotanie obcierającego się w mocowaniu paska do noszenia aparatu, albo jakiś 
najdrobniejszy wietrzyk. Ale prócz tego, jeśli aparat znajduje się w odległości większej niż 1 m od źródła dźwięku, 
dźwięk może nie zostać poprawnie zarejestrowany!, np. filmowanie długą ogniskową oddalonych obiektów.  

 
 

Co dalej? 

Wszystkie aparaty Olympus umożliwiają podłączenie do odbiornika telewizyjnego. 
Do podłączenia aparatu do TV służy Uniwersalne szybkie łącze USB 2.0 Hi-Speed / wyjście audio-wideo 
(NTSC/PAL), poprzez które przesyłamy zapisane filmy (sekwencje wideo) oraz wyświetlamy zdjęcia, korzystając z 
sygnału wideo.  
W tym celu aparat tworzy sygnał Composite Video.  
Composite Video znane również jako acronim CVBS ("Color, Video, Blank i Sync".) - jest wyjściem sygnału wideo 
telewizji analogowej!. sygnał Composite Video czyli Całkowity Zespolony Sygnał Wizji 
Całkowity sygnał wizyjny jest przesyłany pojedynczym kablem współosiowym 75 om (sygnał + masa;  w krótkich 
kablach złe dopasowania impedancji nie ma dużego wpływu na jakości obrazu). Standardowo jest on zakończony 
złączem typu RCA. http://en.wikipedia.org/wiki/List_of_display_interfaces 

http://en.wikipedia.org/wiki/Color
http://en.wikipedia.org/wiki/Video
http://en.wikipedia.org/wiki/Blanking_%28video%29
http://en.wikipedia.org/wiki/Sync
http://pl.wikipedia.org/wiki/Cinch
http://en.wikipedia.org/wiki/List_of_display_interfaces


 
http://www.fachmanowo.pl/forum/viewtopic.php?t=1787  
Kable takie są mało odporne na zakłócenia, a jakość przesyłanego obrazu spada wraz ze wzrostem długości kabla 
łączącego urządzenia (każdy kabel na skutek swoich parametrów zachowuje się jak filtr dolnoprzepustowy).  
Sygnał wizji Composite Video jest przesyłany w jednym ze standardowych formatów NTSC lub PAL.  
Sygnał wideo Composite (kompozytowy) przesyłany za pomocą jednego sygnału zawierającego zmiksowane 
informacje o luminancji i chrominancji. 
Sygnały luminancji (oznaczony jako Y) i zmodulowany chrominancji (oznaczony jako C) przesyłane są tą samą 
parą przewodów.  

 
Widmo sygnału Composite 

 

 

 
Osiągana Rozdzielczość pozioma - Horizontal Line Resolution (HLR) ok. 300 linii.  
 
Composite video (C-Video) sygnał luminancji Y i chrominancji C zostają w dekoderze w telewizorze odfiltrowane 
przez specjalny "Comb filter" (filtr grzebieniowy) - filtr dolnoprzepustowy , ale nie unikniemy zakłóceń, ponieważ nie 
uda nam się tego wykonać perfekcyjnie. Degradacja C spowoduje że kolory nie będą odpowiadać źródłowym. 
Każdy dotychczas produkowany telewizor obsługuje wymieniony rodzaj transmisji. W telewizorze wejście sygnału 
Composite Video jest jako Euro-złącze lub oddzielne wyjście w postaci gniazda Cinch. Ta metoda przesyłu 
sygnału wpływa na jakość obrazu, ponieważ sygnały muszą być dwukrotnie przetwarzane, najpierw w źródle - do 
formy "połączonej", a następnie w odbiorniku - do formy "rozdzielonej". 
 
Myślę, że tyle wystarczy dla nie zainteresowanych szczegółami tematu. 
 
 

Podłączenie aparatu do TV. 
Do podłączenia aparatu do komputera lub TV służy Uniwersalne szybkie łącze USB 2.0 Hi-Speed / wyjście audio-
wideo (NTSC/PAL) 

http://pl.wikipedia.org/wiki/USB 
http://en.wikipedia.org/wiki/Universal_Serial_Bus 

http://www.hardware-bastelkiste.de/index.html?usb.html opis szczegółowy 
Najnowsza wersja uniwersalnych interfejsów szeregowych, pozwala na przesyłanie danych między urządzeniami z 
szybkością do 480 Mb/s. Niestety, gniazdo i wtyczka nie są zgodne ze standardem micro-USB,  

http://www.fachmanowo.pl/forum/viewtopic.php?t=1787
http://pl.wikipedia.org/wiki/NTSC
http://pl.wikipedia.org/wiki/PAL
http://pl.wikipedia.org/wiki/Modulacja
http://pl.wikipedia.org/wiki/USB
http://en.wikipedia.org/wiki/Universal_Serial_Bus
http://www.hardware-bastelkiste.de/index.html?usb.html


 
w związku z tym jesteśmy skazani na korzystanie z kabla wideo CB-AVC3 dostarczonego w zestawie z aparatem. 
 

 
 

Transfer danych z aparatu wynosi ok. 5 MB/s.  
Kabel jest dostatecznie długi, by podłączyć aparat, który leży obok TV, nawet jeśli korzystamy ze złącza 
znajdującego się z tyłu obudowy TV. 
Niestety producent ogranicza długość kabla CB-AVC3. Stąd dla wygody można kupić przedłużacz oraz adapter 
(łącznik) np. f-my VIVANCO. 

 
 

 lub prosty   czy dwa  
 
Adapter [łącznik / trójnik] z serii Sound & Image renomowanego niemieckiego producenta kabli i przewodów firmy 

VIVANCO * dwukierunkowy * w pełni ekranowany 
 



 
Przykładowe typy złącz występujących w TV. 

 
Pamiętamy że wszelkie połączenia pomiędzy TV i aparatem wykonujemy przy odłączonym zasilaniu. Kiedy wtyczki 
kabli będą już na swoich miejscach włączamy odbiornik TV i ustawiamy w nim źródło sygnału, aby był on odbierany 
z wejścia Composite Video. (Jeśli TV posiada tylko wejście Euroscart, musimy dokupić odpowiedni adapter.)  

Teraz włączamy aparat w trybie przeglądania zdjęć i sekwencji wideo  

    
i ustawiamy przyciskiem DISP, taki tryb wyświetlania zdjęć, aby były widoczne tylko zdjęcia (film) bez dodatkowych 
informacji. W tym wypadku odbiornik TV pełni funkcję dodatkowego wyświetlacza.  
Ale możemy jeszcze wykorzystać tą funkcję do zapisu danych na magnetowidzie lub nagrywarce DVD jeśli 
włączymy w nich nagrywanie. 
Jeśli mamy dość długi kabel łączący aparat z TV, to możemy przełączyć aparat w tryb nagrywania i zapisywać 
dane nie tylko na karcie pamięci, ale również taśmie lub DVD. 
 
Aparat SP-570UZ generuje obraz w rozdzielczości PAL 640 x 480 (VGA) o proporcjach szerokości do wysokości 
4:3 (12:9), aby poprawnie ocenić zdjęcia lub film, należy HDTV przełączyć na format obrazu 4:3. 
Rozdzielczość ekranu ma zasadnicze znaczenie dla reprodukcji naszych obrazów. Osiągalna rozdzielczość obrazu 
nie może przekroczyć rozdzielczości ekranu, na którym zostanie on wyświetlony.  
Formatowi PAL 4:3 odpowiada standardowa rozdzielczość (720x576 linii), obraz HDTV jaki zostanie wyświetlony 
na ekranie standardowego TV (SDTV), będzie z czarnymi marginesami na górze i u dołu ekranu!.  
Uwaga: standard europejski TV analogowej zapewnia rozdzielczość obrazu: 702 x 576, rozdzielczość osiągalna 
tylko dla ekranów o sztywnej strukturze rastrowej, takich jak LCD. 
W standardowej pełnej rozdzielczości (SDTV) w formacie 4:3, uzyskamy obraz tylko po przekodowaniu do formatu 
PAL 720x576 linii.   
Należy pamiętać, że:  
 w odbiornikach SDTV wyposażonych w lampę kineskopową liczba widocznych linii obrazu może być 

zmniejszona do ok. Nv = 548 ze względu na 5% overscan, czyli zapas rozmiarów rastra powyżej 
rozmiarów ekranu na zmiany rozmiarów obrazu wywołanych zmianami luminancji sceny.  

 maksymalna osiągalna rozdzielczość obrazu nie może przekroczyć rozdzielczości ekranu.  
czyli, obraz o rozdzielczości źródłowej SDTV pozostanie takim na ekranie o rozdzielczości HDTV,  
a 
obraz o rozdzielczości źródłowej HDTV na ekranie o standardowej rozdzielczości zostanie wyświetlony w 
rozdzielczości SDTV. 
 Każdy telewizor z panoramicznym ekranem o wysokiej rozdzielczości zawiera specjalne układy 

elektroniczne polepszające subiektywne wrażenie jakości wyświetlanego obrazu w rozdzielczości SDTV. 
Fabryczne nazwy np.: CTI, LTI, DNR, SVM, Pixel Plus, INVATEK Engine, 3D DNR, 3D MADI, MPEG NR… 

Dla HDTV występują ekrany o stosunku boków szer./wys. = w/h = 16/9 i dwie liczby wyświetlanych linii obrazu: 
1280x720 i 1920x1080i/p oraz (1366x768p) - jako kompromis pomiędzy stosowanymi filmowymi formatami 
panoramicznymi. 
(„i” interlaced scanning, czyli wybieranie międzyliniowe i p” oznacza progressive scanning, czyli wybieranie kolejno 
liniowe) 
Użytkując odbiornik z ekranem panoramicznym musimy się liczyć z tym, że po przełączeniu odbiornika na format 
4:3, nawet nasz klip przekodowany do formatu PAL 720x576 linii, będzie wyświetlany z pionowymi marginesami z 
obu boków ekranu (Pillarbox), można oczywiście rozciągnąć go do pełnego ekranu, ale spowoduje to utratę 
oryginalnych proporcji. Aby zminimalizować te nieakceptowane przez użytkowników TV zjawiska, nadawcy często 
wprowadzają pośredni format nadawania 14:9, powstający przez wycięcie z oryginalnego formatu 16:9 centralnej 
części obrazu (możliwy do wprowadzenia przez użytkownika w TV funkcją - Auto szer.). 



 
 

 
Stosunek szerokości obrazu do jego wysokości nazywany jest proporcją obrazu (ang. Aspect ratio). 
Jak widać ustalając proporcje, wykorzystano spostrzeżenie, że obrysy formatów najczęściej stosowanych w kinie: 
1.33, 1.67, 1.85, 2.20 i 2.35:1 mieszczą się w obrysie wewnętrznym i zewnętrznym o formacie 1,77:1 (16:9). 
W standardzie PAL 4:3 (lub 12:9) – obraz i piksele są prostokątami o stosunku boków aspect ratio 1,33 : 1. 
HDTV (obraz 16:9; 1,77:1) z założenia ma mieć rozdzielczość dwukrotnie większą niż SDTV (gdzie obraz 12:9), 
więc liczba próbek wyniesie 720*2*16/12 = 1440*4/3 = 1920. Podobnie jak dla SDTV piksele nie będą kwadratowe. 
Musimy jeszcze określić z jakiej odległości powinniśmy oglądać obraz TV?. 
Odległość, z jakiej należy oglądać obraz wyświetlany w TV, zależy przede wszystkim od wielkości ekranu i jego 
rozdzielczości, a dokładnie od liczby linii wyświetlanego obrazu. Musimy tak dobrać odległość, aby patrząc na 
ekran nie dostrzegać struktury liniowej wyświetlacza, z których jest tworzony obraz. Określanie odległości od 
ekranu w zależności od liczby linii wyświetlanych na ekranie wielokrotnością wysokości tego obrazu jest 
najdokładniejszą metodą i niezależną od jego formatu.  
Jak podano powyżej, obecnie spotykamy trzy wartości rozdzielczości pionowej: 
 SDTV – Nv = 576 linii,  
 HDTV – Nv = 720 linii, 
 HDTV – Nv = 1080 linii. 

Minimalna odległość od ekranu wynika z rozdzielczości kątowej oka w kierunku pionowym wynoszącej 1´ (jedna 
minuta łuku). Aby nie była dostrzegalna struktura liniowa wyświetlacza, oko powinno znaleźć się w takiej odległości 
od ekranu, aby jego wysokość W była widoczna pod kątem co najmniej N minut kątowych, gdzie Nv jest liczbą 
wyświetlanych linii obrazu. 

 
Przykładowo dla: 

Nv - ilość rozróżnialnych linii, αo minimalna rozdzielczość kątowa w radianach, D odległości obserwacji.  

Otrzymamy dla D/W = 6 – rozdzielczość kątową ok. 10
o
 

Stąd: Nv = W/D* αo = 1/6 * 60/1 * 180/π ~ 600 linii (~ 576) 

Dokładnie dla SDTV ten kąt wynosi 9,1º (548´), co daje minimalną odległość równą 6,3h lub 3,8d dla stosunku 
boków ekranu szer./wys. = w/h = 4/3, gdzie przekątna d = 5/3h. Kąt widzenia szerokości obrazu w = 4h/3 przy tej 
odległości wynosi 12º.   
Przyjmuje się, że dla kąta widzenia szerokości ekranu j/w ≤ 10º odległość nie powinna być mniejsza od 
czterokrotnej długości przekątnej ekranu kineskopu.  
Natomiast maksymalna odległość nie powinna przekraczać długości pięciu przekątnych, aby nie tracić drobnych 
szczegółów obrazu. 
Dla HDTV N = 720 linii  
kąt widzenia wysokości obrazu wynosi 12º, co daje minimalną odległość od ekranu równą 4,8h. 



Dla HDTV N = 1080 linii 18º, daje minimalną odległość od ekranu równą 3,2h.  
Kąt widzenia szerokości obrazu w = 16h/9, przy tej odległości kąt widzenia szerokości obrazu przyjmuje się w 
zaokrągleniu 20º i 30º otrzymując następujące minimalne odległości od ekranu wyrażone w wielokrotnościach 
długości przekątnej ekranu d = 2,04h,   

stąd: dla 720 linii 2,5d a dla 1080 linii 1,6d. 
Natomiast maksymalna odległość od ekranu nie powinna przekraczać odpowiednio 3,5 i 2,5 długości przekątnych, 
aby nie tracić drobnych szczegółów obrazu. 
Przykładowe dane:   

przekątna  
[cale] 

SDTV (548 linii, 4:3) HDTV (720 linii, 16:9) HDTV (1080 linii, 16:9) 

odległość [m] odległość [m] odległość [m] 

min. maks. min. maks. min. maks. 

32 3,3 4,1 2 2,8 1,3 2 

37 3,8 4,7 2,3 3,3 1,5 2,3 

40 4,1 5,1 2,5 3,6 1,6 2,5 

52 5,3 6,6 3,3 4,6 2,1 3,3 

http://www.centrumdobregoobrazu.pl/tv/ darmowa, interaktywna aplikacja, która pomoże konsumentom dobrać 
telewizor do mieszkania. Aby dokonać symulacji, wystarczy wprowadzić wymiary pomieszczenia, w którym chcemy 
ustawić telewizor. 
 

Tabela (za Audio Video) z jakiej odległości należy oglądać obraz TV, gdy chcemy korzystać z telewizji o wyższej 
rozdzielczości: http://hdtv.com.pl/forum/attachment.php?at...mp;d=1185639847 

 

 

 

 

 

 

 

 

 

http://www.centrumdobregoobrazu.pl/tv/
http://hdtv.com.pl/forum/attachment.php?attachmentid=536&d=1185639847


Montaż i obróbka filmów z aparatu cyfrowego 

Edytowanie i konwersja wideo. 
Edytor wideo (wideoedytor) - program komputerowy do cięcie, konwertowania, montażu, przeróbki video 
cyfrowych filmów. 

Najbardziej znane wideoedytory dla domowego użytkownika to np.: Adobe Premiere Pro, Pinnacle Studio, Ulead 
VideoStudio,oraz freeware  Windows Movie Maker 2, VirtualDub 1.9.4, AviDemux 2.5.0 itd. 

Windows Movie Maker wchodzi w skład Windows XP lub Vista. Może być bezpłatnie ściągnięty z strony Microsoft 
 
Jak już podano filmy w SP-570UZ są zapisywane są do pliku AVI Motion JPEG

®
. Dźwięk: format: WAV    

Jeśli nie odpowiada nam ten format, to możemy dokonać konwersji na format, który umożliwi nagranie VCD; DVD i 
odtwarzanie na stacjonarnym odtwarzaczu za pomocą np. Format Factory lub VirtualDub czy AviDemux 
 

Format Factor już v2.0:  

 
o dziwo jest darmowy (ewent. dotacje) i po polsku!  (suport 48 języków) 
Aplikacja jest rozbudowanym konwerterem plików audio, wideo i graficznych. W sumie program odczytuje 29 typów 
plików wideo, 21 audio i 20 graficznych.  
Zapis jest możliwy w: 
- 12 formatach wideo, wszystko do:  

urządzeń mobilnych/MP4/3GP/MPG/AVI/WMV/FLV/SWF/MKV/VOB/MOV/GIF 
- 12 audio: MP2/MP3/WMA/AMR/OGG/AAC/WAV/WAVpack/ FLAC/M4R/M4A/MMF/ 
- 8 graficznych:  JPG/BMP/PNG/TIF/ICO/GIF/TGA/PCX/ 
Wczytane do program pliki możemy zapisać w innym formacie, zmieniając takie parametry jak rozdzielczość, liczba 
klatek na sekundę (filmy), czas trwania czy bitrate. 
Program jest wyposażony w moduł listy, wczytujemy do niej wiele różnych plików, ustalamy parametry ich 
kompresji i uruchamiamy proces. Zadania zostaną wykonane kolejno, a jeśli to realizujemy w nocy to po 
zakończeniu może wyłączyć komputer. W oknie ustawień danej konwersji możemy precyzyjnie określić dużo 
parametrów, nawet dodać napisy z pliku tekstowego (formaty: SRT, SSA, SUB i TXT MicroDVD), które będą 
wmontowane w obraz wideo. Format Factory pozwala również przegrać na dysk komputera wideo z płyt DVD i 
muzykę z płyt CD Audio. 
Uwaga: pliki (klipy) mp4 tworzy w formacie QuickTime (*.mp4), codec ID – mp42 (H.263); audio - AAC  
 
 

http://www.microsoft.com/windowsxp/moviemaker/downloads/moviemaker2.asp


VirtualDub już v1.9.4 

 
- narzędzia do przechwytywania obrazu i obróbki plików wideo. Aplikacja charakteryzuje się dużymi możliwościami 
konfiguracyjnymi. Wśród interesujących opcji jest m.in. funkcja przycinania plików AVI. Z programem zintegrowany 
jest odtwarzacz wideo. Co można za jego pomocą wykonać:  
- pobawić się w montażystę filmowego łącząc różne filmy ze sobą,  
- wycinać część filmu,  
- zmieniać rozdzielczość filmu,  
- zrzucić wybrane klatki z filmu do popularnych formatów graficznych,  
- zrzut dźwięku z filmu do osobnego pliku w wav, następnie można za pomocą konwerteru przerobić taki plik do 
mp3, acc, ogg i innych formatów muzycznych,  
- zastosować efekty specjalne w filmie,  
- konwersje do innego formatu z zastosowaniem różnych kodeków np. DivX, XviD...,  
- dodać tekst na filmie,  
- dodać dźwięki, muzykę.  
Ponadto program współpracuje ze skryptami, a zaawansowane opcje VirtualDub dostępne będą po instalacji 
wtyczek. 
Nowe wersje VirtualDub obsługują sekwencje wideo z wykorzystaniem kodeka AVI Motion JPEG

®
, nie odczytuje 

plików formatu mp4. 
 
Przykładowe dane: 
Wykonano - krótką sekwencję wideo PAL 640x480px + WAV 35 sek. Otrzymano klip AVI = 56MB  
Policzmy przykład:  
Zakładamy, że nagrywamy obraz telewizyjny PAL ma 640x480 punktów wyświetlanych jako 30 klatek w ciągu 
sekundy, przy czym kolor każdego punktu opisany jest 24-bitową wartością (3 bajty) – i nie stosujemy żadnej 
kompresji: 
Plik jedno sekundowy zajął by zatem: 

640x480x3x30 = 27648000 bajtów = 27648000/1024
2
 = 26.37MB 

WAV – ośmiobitowy dźwięk mono z stałą przepływnością CBR (ang. constant bit rate) = 64kb/s 
Dla 35 sekund otrzymamy: 

26.37MB x 35 = 922.95MB 
64kb/s x 35 = 2240kb = 0.002MB 

Sumarycznie 923MB 
Przy zastosowaniu kompresji obrazu z wykorzystaniem kodeka AVI Motion JPEG

®
, otrzymaliśmy plik: 56MB, 

czyli uzyskany współczynnik kompresji wynosi 16.5 : 1 
po konwersji na (MPEG2) DVD PAL  Large 720x576px, rozmiar pliku 26,8MB 

po konwersji na MP4, rozmiar pliku 9,2MB 
MPEG-4 cechuje się 6 razy większą kompresją danych niż standard MJPEG przy tej samej jakości obrazu. 

http://forum.doom9.org/showthread.php?t=96059    MPEG-4 AVC/H.264 Information      2009-06-17 

 
 
 
 

http://forum.doom9.org/showthread.php?t=96059


AVI Frame Rate Changer jest programem umożliwiającym zmianę liczby klatek na sekundę (frame ratio) w plikach 
AVI bez potrzeby przeliczania całego filmu. http://www.cdrinfo.pl/download/1187024410  

 
ale niestety, będziemy mieli do czynienia ze zjawiskiem desynchronizacji strumieni audio i wideo!!!!  

Nie będzie problemu dla sekwencji wideo bez dźwięku. 
 
Dla sekwencji wideo z dźwiękiem, stosujemy VirtualDub - zmiana frame rate (liczba ramek/s)  
a) menu File->Open video file (wybieramy film)  
b) menu Video->Direct stream copy  
c) menu Audio->Direct stream copy  
d) menu Video->Frame rate…  
Wybieramy z sekcji Frame rate conversion opcję Conwert to fps: … 
frames per second i określamy liczbę klatek na sek. np. 25  
e) menu File->Save as AVI 

  Frame rate - to podmenu zawiera różne ustawienia dotyczące klatek materiału wyjściowego. Po wybraniu tej 

opcji ukazuje się okienko z trzema ramkami:  

 Source rate adjustment - pozwala na regulację ilości klatek na sekundę, czyli frame rate lub inaczej fps 
(frames per second).  

 No change - pozostawia wartość z materiału wejściowego, która wyświetlana jest w nawiasie po prawej 
stronie.  

 Change to - zmienia wartość na wskazaną.  
Przydaje się, gdy film ma fps większe niż 25, wówczas pozwala to na zmniejszenie jego rozmiaru. 
Odwrotna zmiana (z wartości mniejszej na większą) nie żadnego sensu.Zmiana frame rate powoduje 
desynchronizację strumieni audio i wideo. 

 Change so video and audio durations match - dopasuj fps do strumienia audio.  
Opcja ta synchronizuje, ścieżki audio i wideo (oczywiście tyko wtedy, gdy nie są zsynchronizowane). 

 Frame rate decimation - nazwa tej funkcji w wolnym tłumaczeniu oznacza "dziesiątkowanie klatek".  
Funkcja ta pozwala usuwać wybrane klatki ze strumienia wideo, zostawiając na przykład tylko co trzecią 
czy siódmą, przy czym strumień dźwięku nie ulega zniekształceniu i odtwarzany jest prawidłowo. W ramce 
dostępne są następujące opcje: 

o Process all frames - pozostawia klatki bez zmian (funkcja nieuaktywniona).  
o Process every other frame (decimate by 2) - zostawia co drugą klatkę.  
o Process every third frame (decimate by 3) - zostawia co trzecią klatkę.  
o Decimate by - pozwala samemu wybrać krotność zostawianych klatek.  

 

 Inverse telecine (3:2 pulldown removal) - odwrócenie procesu telecine.  
Proces ten jest związany z kodowaniem obrazu w systemie NTSC. 
 
VirtualDub - Kodowanie i filtry  
załóżmy że mam plik avi P8072387.avi (AVI Motion JPEG

®
 +WAV). Otwieram ten plik w VirtualDub. Ustawiamy 

opcje:  
a) menu File->Open video file (wybieramy sekwencję wideo)  
b) menu Video->Full processing mode  
c) do wyboru :  
- jeżeli chcemy pozostawić oryginalny dźwięk to : menu Audio->Direct stream copy  
- jeżeli zmieniamy format : menu Audio->Full processing mode (wybieranie rodzaju kompresji menu  
Audio->Compression potem z listy po lewej kodek audio a po prawej bitrate)  
d) menu Video->Compression (wybieramy kodek z listy i wciskamy Configure, teraz należy określić parametry 
przede wszystkim bitrate video)  
Bitrate - prędkość strumienia danych - parametr wykorzystywany przy podawaniu współczynnika kompresji 
audio/wideo. Im większy Bitrate tym lepsza jakość ale i więcej zajętej przestrzeni na dysku twardym, płycie itp. 
Bitrate podaje się w ilości bitów na sekundę (bps). Stosowanie bitrate'u mniejszego niż 1500 kbps (gdy parametr 
bits/(pixel*frame) spada poniżej 0.20) spowoduje znaczną utratę jakości - częstsze występowanie makrobloków, 
itp. Ustawiając bitrate na około 1800-2200 kbps, parametr bits/(pixel*frame) oscylował będzie w granicach od 
0.25 do 0.30, a więc jakość porównywalna z dobrymi kopiami filmów. 

http://www.cdrinfo.pl/download/1187024410


e) menu Video->Filters  
Na tym etapie możemy dodać różne filtry przetwarzania obrazu wideo np. zmiana rozdzielczości, napisy i wiele 
innych.  
Dodanie filtru : naciskamy przycisk Add i z listy wybieramy określony filtr (np. resize potem wciskamy OK i 
określamy rozdzielczość oraz algorytm interpolacji.  
Na tym etapie możemy również wyciąć czarne pasy : naciskamy przycisk Cropping i określamy offset dla dolnych i 
górnych x,y (będzie widoczna ramka)  
f) menu File->Save as AVI jako :Moj_film_1.avi (i rozpoczyna się kodowanie) 
 
VirtualDub - Wycinanie części filmu (wycięta część zostaje usunięta)  
Ten sposób wykorzystuje się do usuwania nieciekawych części filmu  
a) menu File->Open video file (wybieramy film)  
b) menu Video->Direct stream copy  
c) menu Audio->Direct stream copy  
d) Znajdujemy początek fragmentu do wycięcia.  
Można to zrobić wskazując określone miejsce suwakiem lub wybierając z menu  
Edit->Go to i wpisując numer klatki lub czas.  
Jeżeli to początek to z menu Edit wybieramy Beginning  
e) menu Go ->Next keyframe  
f) menu Edit->Set selection start  
g) Znajdujemy koniec fragmentu w ten sam sposób co początek.  
Jeżeli jest to koniec to z menu Go wybieramy End.  
h) menu Go->Next keyframe  
i) menu Edit->Set selection end  
j) menu Edit->Delete selection  
k) menu File->Save as AVI 
 
File Information - wyświetl informacje o otwartym pliku.  
Po wybraniu tego polecenia wyświetla się okno z dwiema ramkami, przy czym informacje tam zawarte mogą się 
różnić, w zależności od formatu pliku.  
Oto najczęstsze: 

 Video track - informacje dotyczące strumienia video:  
Frame size, fps - rozdzielczość (w pikselach), ilość klatek na sekundę, czas wyświetlania klatki (w 
mikrosekundach na klatkę).  

 # of frames (time) - całkowita ilość klatek i czas materiału  

 Decompressor - nazwa zastosowanej kompresji wideo  

 Number of keyframes - liczba klatek kluczowych  

 Number of I, P and B frmes - ilość klatek poszczególnego typu  

 x-frame min/avg/max/total frame size - informacje o klatkach poszczególnego typu (I, P, B)/(key frames, 
delta frames). Są to kolejno: wielkość minimalna , średnia, maksymalna oraz całkowita (wielkość 
wszystkich klatek danego typu).  

 Average bitrat - średnia prędkość bitowa (w nawiasie podana w kilobajtach)  

 Audio track - informacje dotyczące strumienia audio  

 Format - częstotliwość próbkowania, tryb (mono/stereo), nazwa zastosowanego kodeka audio (często z 
podaną prędkością bitową)  

 # of frames - liczba kaltek  

 Total size - całkowity rozmiar strumienia audio  
Load processing settings - ładuje plik (skrypt) z ustawieniami.  
Save processing settings - zapisuje ustawienia programu w pliku (rozszerzenie .vcf).  
Opcja bardzo się przydaje, gdy często korzystamy z tych samych ustawień programu, skracając czas potrzebny na 
konfigurację programu. 
 
Łączenie dwu lub więcej sekwencji wideo. 
VirtualDub`a możemy wykorzystać aby połączyć dwie lub więcej sekwencji wideo ze sobą.  
Ważne jest to, aby pliki miały takie same parametry: musza być identyczne (ten sam kodek, ten sam bitrate, taka 
sam rozdzielczość, itd.). 
 

 
 
 
 
 
 



AviDemux http://fixounet.free.fr/avidemux/  Avidemux Wiki 

 
AviDemux to wieloplatformowy edytor wideo na licencji GNU GPL.  
AviDemux to doskonale dopracowane narzędzie do edycji i kompresji plików video dostępne na różne platformy 
systemowe. Aplikacja pozwala nam nie tylko zmienić format, przyciąć obraz, czy dodać ścieżkę dźwiękową do 
filmu, ale i nałożyć na niego różnorakie filtry, zmiana rozmiaru i jakości, dołączanie odpowiednich ścieżek 
dźwiękowych i napisów, wyostrzanie obrazu, equalizer, efekt wyciszania, bramka szumów, rozmycie lub poświata 
pomogą nam one wydobyć to, co najlepsze z obrazu. 
Avidemux to narzędzie do ekspresowej edycji oraz konwersji wideo. Jest niezależny od zainstalowanych w 
systemie kodeków i filtrów (bazuje przede wszystkim na libavcodec). Obsługuje najpopularniejsze formaty plików 
oraz nośników AVI, MPEG-1, MPEG-2, MP4, OGM, FLV, MKV i nie tylko (częściowo MOV, WMV, ...).  Poprzez 
avsproxy obsługuje skrypty AviSynth.  
Program również wykonuje kompresje między formatami filmów np z MPEG do AVI, VCD, SVCD i DVD i inne.  
Avidemux posiada przejrzysty interfejs, co sprawia że obsługa aplikacji jest bardzo prosta.  
Większość funkcji dostępna jest z poziomu górnego menu. Trzeba przyznać, że nie jest ich mało. Avidemux może 
wycinać dowolny fragment pliku, wstawiać go w inne miejsce, zmieniać niezliczoną liczbę parametrów obrazu oraz 
dźwięku za pomocą specjalnej biblioteki filtrów, a także konwertować gotowy film do najpopularniejszych formatów, 
w tym również dostosowanych do odtwarzania w multimedialnych urządzeniach przenośnych. Posiadaczom 
większej kolekcji plików wideo do obróbki z pewnością przyda się moduł kolejkowania zadań. 
Przy jego pomocy mżemy zmienić kontener na MP4. Wystarczy przy Video i Audio nie ustawiać żadnego kodeka, 
tylko opcję "Copy". Dwie minutki i mamy film w nowym kontenerze. Gspot prawidłowo odczytuje informacje o 
zawartości, a VLC odtwarza prawidłowo... 
 
Wczytujemy do programu pliki File > Open... (Ctrl + O).  
Uwaga: AviDemux v. 2.5 nie obsługuje sekwencji wideo z wykorzystaniem kodeka AVI Motion JPEG

®
. 

Wybrane opcje programu:  
- Video > Filters - Spora ilość filtrów, między innymi: zmiana wymiarów, kontrastu, obrócenie filmu, dodanie 
obwódki, zmiana ilości klatek, wyciszenie, dodanie ostrości, zmianę kolorów, ucięcie obrazu z wybranej strony i 
wiele innych.  
- Tools > Calculator - kalkulator do przeliczana np. jakiej wielkości filmik w formacie MPG zmieści się na płytę CD,  
- Przeskok do wybranej klatki lub określając czasowo położenie filmiku,  
- Wycinanie i wklejanie fragmentów filmików,  
- Ustalanie ile klatek na sekundę ma mieć stworzony klip,  
- Zapis zrzutu wybranej klatki z klipu do formatu bmp lub jpg,  
- Zbiorcze informacje na temat danego pliku wideo,  

http://fixounet.free.fr/avidemux/
http://www.avidemux.org/admWiki/index.php?title=Main_Page


 
Przykładowo Skorzystamy: 
Copy dla Audio i Video,  
Format = MP4,  
dołączenie następnego pliku wideo - opcja Append...  
Oczywiście łączone pliki powinny mieć te same właściwości. 
Przykładowy opis konwersji: 
1. Klikamy na "OPEN" i wybieramy plik sekwencji wideo. 
2. W polu po prawej "VIDEO" wybieramy kodek wideo lub pozostawiamy na "COPY (przekopiowany zostanie 
oryginalny format z pliku wejściowego". 
3. W polu "AUDIO" wybieramy kodek audio lub pozostawiamy na "COPY". 
4. w polu "FORMAT" wybieramy kontener do zapisu pliku wideo. 
5. Gdy chcemy zapisać tylko fragment filmu to zaznaczamy wybrany fragment przyciskami oznaczonymi literami 
"A" i "B" (Selection" start i Selection: end). 
6. Klikamy na "SAVE" wprowadzamy nazwę dla pliku i czekamy na aż zakończy się konwersja. 
 
 
 
GSpot 2.70a Freeware 
http://gspot.headbands.com/  lub z dowolnej innej strony internetowej 
program do wykrywania kodeków użytych np. w wybranym filmie. Po wczytaniu pliku AVI otrzymamy informacje 
jaką odmianą kodeka zostało zakodowane video (Video Format), audio (Audio Format) oraz czy w systemie 
posiadamy zainstalowane odpowiednie kodeki do oglądnięcia filmu. Program podaje też dodatkowe informacje o 
pliku: rozdzielczości video, ilości klatek oraz jakości video i audio. Przydatną opcją jest możliwość wykonania 
symulacji (Render) czy plik zostanie poprawnie otwarty. Za pośrednictwem programu poznamy też listę kodeków 
audio i video zainstalowanych w systemie. 

 
 
 
 

http://gspot.headbands.com/


lub 
AVIcodec 1.2 Build 110: 
http://www.download.net.pl/98/AVIcodec/  
Następny program dzięki któremu uzyskamy informacje o pliku avi, łącznie z określeniem jakim kodekiem został 
skompresowany film. Program wyświetla szczegółowe informacje o kodekach i filtrach niezbędnych do odtworzenia 
danego pliku wideo. Dodatkowo wyświetlane są informacje o pliku wideo, takie jak jego rozdzielczość, liczba 
klatek, proporcje obrazu, prędkość, kompresja, liczba kanałów audio. Obsługiwane są formaty: AVI, ASF, WMV, 
Real, OGG, MPG i VOB. 
Aplikacja sprawdza również czy w systemie jest zainstalowany kodek dla obrazu lub dźwięku konieczny do 
odtworzenia filmu. 

 
 

Do odtwarzania: 
Playery (odtwarzanie): Windows Media Player;  Quick Time Player;  VLC media player,  Media Player Classic; 
BEST player; -  umożliwiają odtwarzanie plików strumieniowych (także MPEG-4), oraz standard kodowania 
dźwięku AAC (Dolby Advanced Audio Coding), obsługuje również coraz bardziej popularny format H.264. 
 
 
 
Opracowanie: 
Zbigniew Małach 
Zbyma72age 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Poradnik nie może być publikowany w całości lub fragmentach na innych stronach www lub prasie, bez 
wcześniejszego kontaktu z autorem poradnika oraz bez zgody na publikację.  

http://www.download.net.pl/98/AVIcodec/

